Support » Plugin: WordPress Gallery Plugin - NextGEN Gallery » Problems with cyrillic

  • Resolved Alagos

    (@alagos)


    When cyrillic used to replace [Show slideshow] error occured on gallery edit.

    Uncaught DOMException: Failed to execute 'btoa' on 'Window': The string to be encoded contains characters outside of the Latin1 range.
        at B.<anonymous>

    In previous gallery versions cyrillic works fine.

    • This topic was modified 5 years, 6 months ago by Alagos.
    • This topic was modified 5 years, 6 months ago by Alagos.
Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author photocrati

    (@photocrati)

    @alagos – I’m not seeing how that would happen although it would definitely be of interest to learn more specifics of the problem. Please share the exact text you are using that is creating this message so we can test it ourselves.

    Thanks!

    – Cais.

    Thread Starter Alagos

    (@alagos)

    Hi @photocrati
    The default text from gallery configuration is:

    [Show slideshow]

    And russian translation:

    [Показать слайдшоу]

    Steps to reproduce:
    – Create new gallery and insert it in post
    – Change link text from [Show slideshow] to [Показать слайдшоу]
    – Open browser console and press edit gallery icon

    Result:
    Exception occures.

    Plugin Author photocrati

    (@photocrati)

    @alagos – Thanks for those details; I was able to reproduce an existing issue we are trying to sort out (although I am not seeing the error message you have found). I’ve updated our internal notes on this problem with the details from this topic although I do not have an ETA for when we will get it resolved.

    As it is, the specific problems, appear to only be seen when using Cyrillic characters (and possibly only with the Show Slideshow link text field?!).

    – Cais.

    Thread Starter Alagos

    (@alagos)

    Hi @photocrati

    What is your WP version?
    In this thread tags mentioned WP version 4.7.2 and my current version is 4.7.3.

    It seems that in previous plugin versions cyrillic slug also cause problems, but I couldn’t reproduce it currently.

    Also old versions of galleries inserted to post with gallery id couldn’t be edited. Removing gallery id helps to solve this.

    So for now only case what I can reproduce – is show slideshow link text described above.

    Thank you for your time and response.

    Plugin Author photocrati

    (@photocrati)

    @alagos – The WordPress current version is not an issue (and has not been a problem ever that we are specifically aware of).

    We will be reviewing the parameter value (specifically the data point of using Cyrillic) in regards to another edge-case issue as it provides the means to reproduce an issue we previously were not able to.

    The ID parameter issue is also known, we hope to have it corrected soon. It was originally designed to provide backward compatibility with the old <img> tag placeholder inserted displays.

    Thanks!

    – Cais.

    • This reply was modified 5 years, 6 months ago by photocrati.
Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Problems with cyrillic’ is closed to new replies.