Support » Fixing WordPress » Cyrillic characters evade WordPress Disallowed Comment Keys

  • Our WordPress Disallowed Comment Keys settings include the words “casino” and “casinos” but comments with the Cyrillic character Es (Cyrillic) which looks like a “c” go on through. In other words comment containing “Bеst оnlinе cаsino” goes on through because it is not the Latin character “c”.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Dion

    (@diondesigns)

    I think you should ask your question in the support area for whatever plugin added “disallowed comment keys” to WordPress.

    In general, though, trying to ban words is much like trying to ban IP addresses — at best it’s a game of whack-a-mole and at worst it’s a complete waste of time. If you ban words containing Cyrillic characters, people will use HTML entities. And so it goes…

    Thread Starter DickRaney

    (@dickraney)

    That is core WordPress under Settings > Discussion

    Dion

    (@diondesigns)

    Hmm…so it is. I thought that option was called Comment Blacklist, but I guess the name was recently changed. Tells you how much I use WP comments. (I much prefer to use a bridged discussion board for comments.)

    In any case, my response above still stands. It’s generally a waste of time trying to ban words/phrases due to how easy it is to circumvent the bans. However, if you really want to ban custom phrases containing Cyrillic characters, I’m sure they can be entered into the provided textarea.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.