Support » Plugin: CyberSEO Lite (CyberSyn) » cyberseo_post_link custom field not good for first post

  • Resolved marcetin

    (@marcetin)


    Hello,
    I have tried old Version 3.29 which works but for first item from feed do not get right cyberseo_post_link value.

    As I figure out by examine what is happening it get first <link rel=”alternate”> from feed for first post but it should be first under a <entry> so for fist post it always place http://SOME-SITE in to cyberseo_post_link

    This is example how looks feed I am pulling:

    <feed xml:lang="en-US" xmlns="http://www.w3.org/2005/Atom">
    <link rel="alternate" type="text/html" href="http://SOME-SITE"/>
    <entry>
         <link rel="alternate" type="text/html" href="http://SOME-SITE/post1"/>
    </entry>
    <entry>
         <link rel="alternate" type="text/html" href="http://SOME-SITE/post2"/>
    </entry>

    cyberseo_post_link custom field should be for every post http://SOME-SITE/postX but first post’s cyberseo_post_link custom field is always http://SOME-SITE

    Is there any chance you fix that?

    It will be the best if we could have cyberseo_post_link as <entry><link rel=”alternate”> URL and cyberseo_source_site as root <link rel=”alternate”> from feed.

    https://wordpress.org/plugins/cybersyn/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author CyberSEO

    (@cyberseo)

    Currently the plugin picks up the link from the RSS <link> sections that have the following format:

    <link>http://SOME-SITE/postX</link&gt;

    That is true for other posts than first.

    But for first it pick first <link> in feed.

    For example please try to import http://themeforest.net/feeds/new-wordpress-slash-retail-items.atom and you will see that cyberseo_post_link custom field is not good for first imported post, it is <link>http://SOME-SITE/</link&gt; not <link>http://SOME-SITE/postX</link&gt; , it seem like it takes first <link> from feed and attach it to first post although it should pick <link> from <entry> not any first <link>.
    I hope you understand what is my problem.

    Also if enabled Link to source first post from feed have link to http://SOME-SITE/

    I found the solution!

    Change this:
    if ($name == "LINK" && isset($attribs['HREF']) &&

    to this:
    if ($this->insideitem && $name == "LINK" && isset($attribs['HREF']) &&

    Plugin Author CyberSEO

    (@cyberseo)

    Thanks for the solution! The mentioned bug has been fixed.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘cyberseo_post_link custom field not good for first post’ is closed to new replies.