Support » Theme: Customizr » Customizr Menu won't update

  • Resolved helpingmedia

    (@helpingmedia)



    Hi,

    I can’t change the main menu on my site Media Ideas. I have updated it in the backend and deleted the old menu, but the changes are not showing on the live site.

    I have tried switching to other themes and the menu works fine, with the backend display replicated on the live site.

    But when I activate Customizr again the old problem occurs; the backend menu is different from the live site.

    I uninstalled Customizr, cleared my cache, history etc and Customizr was still showing with the wrong menu despite me having another theme set.

    I deleted Customizr and then reinstalled Customizr and the problem is still there.

    Any clues? I would like to keep the theme, but I can’t if I am not able to update my menu.

    David

Viewing 15 replies - 1 through 15 (of 15 total)
  • Hi,

    I am still looking for a solution to this problem and have posted here and several times in the general forum where I was advised to post here again. Rather than start another thread I thought I should add some more information.

    It seems that there is an old version of the top navigation to my site MediaIdeas stored somewhere which results in an incorrect display when viewed on a laptop or desktop. When viewed on mobile the correct version shows.

    Any help gratefully received.

    David

    Can you give some idea of what the new menu looks like and what the old menu is like? I am not able to make out whether what I am seeing is the new menu or old menu

    Sure, I don’t think I am able to add images to this forum so I will have to give you links to the screen shots which I have uploaded to my server.

    1. Correct menu as seen from the backend
    2. Correct menu as seen on the mobile version
    3. Old menu as seen when the site is viewed on a laptop

    It’s the drop down list of earlier project work in 2012/2013/2014 seen in the third link which I can’t get rid of. I have removed it in the backend, it’s gone on the mobile version, but it is still there on the pc/laptop version.

    As I mentioned earlier, I have cleared cache, have the latest version of WordPress and the Customizer theme and all the plugins are up-to-date. And the problem is not to do with my computer, I get the same issue when viewing on other laptops and macs.

    David

    Just a thought, but could it be that my server is not running the latest version of PHP?

    Flagged to developers

    Thanks Menaka, let’s hope they can come up with a fix. David

    Hello,
    opening your home page source.

    I see:
    <!-- WP Fastest Cache file was created in 2.42060112953 seconds, on 13-05-15 9:35:59 Mozilla/5.0 (compatible; bingbot/2.0; +http://www.bing.com/bingbot.htm)-->

    so the served version of the page is the one created on 13-05-15
    So it depends on that plugin and not on the theme.

    Did you clean that plugin cache?

    For some reason (maybe a setting?) that plugin doesn’t serve the cached files to mobiles, that’s why you can see the “new” menu on mobile devices.

    Hope this helps.

    Hi d4z_c0nf, thanks so much. That’s fixed it, but it took some time.

    When I checked I couldn’t find any plugin called WP Fastest Cache, and then I remembered that I deleted it some time ago, so I guess it had left some residual files.

    I installed it again and it was telling me to change file permissions, so I deleted it again, reinstalled the latest version of WordPress and the site is now working fine.

    Thanks for finding the issue.

    David

    Glad you solved David 😉

    Great deduction d4z_conf

    Thanks Menaka S. .. it’s just a matter of experience 😉
    You’ll see that often caching plugins leave some obvious traces in the source html.
    And often happens that even when they are not active( or even removed) already built cache is served, I might suppose they put something in the DB they don’t remove on plugin removal..
    Plus I was exactly looking for a caching plugin footprint as the issue symptoms were compatible with that 😀
    See you.

    Hello I have a word-press site http://www.southerncaliforniasoberliving.com I have been trying to correct a misspelled word in the menu bar but no matter what I do it won’t update on the live site. It’s updated in the back-end but it won’t change live? Can anyone help?

    Hi @bigjv
    Please open a new thread for your issue

    How? Where?

    Can’t I just get some personal developer help to solve my issue?

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Customizr Menu won't update’ is closed to new replies.