Support » Theme: Customizr » Customizr Featured image not showing on page

  • I have a couple of questions regarding the customizr theme:

    1) I have added a featured image to one of my pages. I have set this page to be a featured page on my homepage. The picture shows up in the circle on the homepage, but when I click on the article, no picture. I have featured images set up on my posts, and the picture shows up on the actual post. I must be missing a setting or something.

    2) Why am I not able to size an image from within wordpress itself, using the customizr theme?

    3) On the posts, when the featured image does show on the actual post, the images are distorted. The instructions show 270×250 as the image size for the thumbnail, but then on the post itself, you are able to choose to have the picture the full width of the post, and then the image becomes distorted.

    • This topic was modified 2 years, 9 months ago by  skmorrow.
Viewing 9 replies - 16 through 24 (of 24 total)
  • The question was about pages and not posts. You can set (the position) of the featured image for the posts fine. But I can’t find where to do this for pages. Or is there an other ‘quick fix?

    Hello, I am having the same issue. I have recently taken over support of a customizr child theme. The featured images stopped showing up on Pages. Not posts. Featured images associated with news posts are showing up fine however the featured images associated with pages are not showing up on the page.

    I am rather new to WordPress, and assume that when I updated the WP version, it created this issue.

    Help??

    I have exactly the same issue.

    Featured images don’t appear when I share my pages.
    When I post one page on Facebook for instance, or send the link of the page to someone, I don’t see my featured image but sometimes the logo of my website, some other times the square favicon and other times nothing at all, just the copy.
    So, what’s the use of the featured image on pages if if doesn’t appear anywhere?

    To make things clear, featured images DO APPEAR ON POSTS.

    It seems problem is not solved for neither of us here.

    Same issue here. No featured images on pages. Version 3.5.11

    Something we are missing or a bug?

    Did anyone get resolution on this? I’m using CustomizrPro, just upgraded to the latest version and I have the problem of featured images not displaying on POSTS. Pages are working! Tried all the options Denzel suggested.

    Just thought I’d ask before I open a support call. TIA

    As a JFYI – following support from Denzel, I disabled photon (was using WordPress 4.7.5 and Customizr Pro 1.4.0 ) still did not see featured images on either posts or pages. (I had used sliders on pages instead of featured images)
    So upgraded to wordpress 4.8 then turned back on all my plugins, testing in between. All working now. Fingers crossed I haven’t broken anything else.

    I have put a featured images in the pages I want to put on the featured pages section and saved the pages and refreshed the website and my images do not show up. Any suggestions?

    I posted a similar problem with a blog: Featured image not shown
    https://wordpress.org/support/topic/after-migration-featured-image-src-empty-for-new-post/

    I found the problem for this blog, php5-gd was not installed.
    On the Debian,
    – I had to install it (sudo apt-get install php5-gd)
    – restart the http server

    Hope it will help some of you.

    Same problem here. Featured images show on posts, but not on pages. The settings for image position are the same for posts & pages.

Viewing 9 replies - 16 through 24 (of 24 total)
  • The topic ‘Customizr Featured image not showing on page’ is closed to new replies.