Support » Themes and Templates » Customizing this Swatch theme…

Customizing this Swatch theme…

  • Okay guys, I’ve got my site set up at: http://www.ecoblu.zymichost.com

    WordPress installation went fine, insatllation of the free theme, Swatch, went awesome. Now, I’m just trying to customize it the way I need. Problem is, the theme does not come with any support.

    What I’m wanting to do, is to edit the areas on the homepage that say: ‘Home’, ‘Portfolio Snapshots’, and ‘Hits from the Blog’.

    I figured out how to edit the ‘Home’ area, but the Portfolio Snapshots and Blog posts is just impossible to edit for some reason? Can anyone help out with this?

Viewing 15 replies - 1 through 15 (of 27 total)
  • They seems to be widgets… have you looked into Appearance > Widgets ?

    Wow, egado, thanks for the quick response. That was it! This theme is honestly AMAZING….

    Wish you a lot of fun with wordpress and your theme 🙂

    Thanks! and I also have another question…

    If you look at my site, do you see the line at the top of all different colors? Is there anyway to get rid of it? I’m guessing I should look in the CSS file?

    Please excuseme, I’m very new to CSS anddefiitely not an expert. So if you’re about to give me some CSS instructions, please be fully explanable. Thanks =]

    1. childtheme
    If you want to make changes on the theme, you better create a childtheme of it http://codex.wordpress.org/Child_Themes otherwiese if your theme get an update, your changes may be lost… but if you want to try it out without a childtheme follow 2. 🙂

    2. Open the style.css and find

    #wrapper {
        background: url("images/wrapper-bg-colourstrip.png") repeat-x scroll left top transparent;
        padding-top: 5px;

    3. Change it to

    #wrapper {
        background: url("images/wrapper-bg-colourstrip.png") repeat-x scroll left top transparent;
        padding-top: 5px;

    4. open blue.css and find

    #wrapper {
        background-image: url("blue/wrapper-bg-colourstrip.png");

    5. change it to

    #wrapper {
        background-image: url("blue/wrapper-bg-colourstrip.png");

    so the colored line should disappear… let me know if it works you…

    Awesome, that should work, ill try it in a second. Im having another problem now =/

    When adding an image as a Slide, the image doesnt appear, and gives me this error when I right click>view image:
    A TimThumb error has occured
    The following error(s) occured:

    Could not create the index.html file – to fix this create an empty file named index.html file in the cache directory.
    Could not create cache clean timestamp file.

    Query String : src=wp-content/themes/swatch/images/iballbanner.png&w=900&h=338&zc=1&q=90
    TimThumb version : 2.8.10

    Any ideas?

    Could not create the index.html file – to fix this create an empty file named index.html file in the cache directory.

    try that 😉

    I have no other idea, don’t know much about TimThumb… sorry 🙁

    TimThumb is giving me LOADS of errors…

    Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File(/www/wp-content/themes/swatch/images/iballbanner.png) is not within the allowed path(s): (VIRTUAL_DOCUMENT_ROOT) in /www/zymichost.com/e/c/o/ecoblu/htdocs/wp-content/themes/swatch/functions/thumb.php on line 861

    [ Repetative log entries removed. ]


    Moderator Jan Dembowski


    I think that’s something your host will need to address.

    Give this a read http://stackoverflow.com/questions/223800/how-can-i-relax-phps-open-basedir-restriction for an example of what I mean.

    Hi, I am having the same problem
    I can’t delete the “Portfolio Snapshots” and ‘Hits From Blog’

    My widget area is also clear..
    Kindly help

    I know this topic is old, but I have found that instead of changing all of that code that @egado said to change, all you have to do is go into style.css and change the #wrapper padding to 0px. Doing it the other way messes up the home page.

    Hi Folks,

    I am also stuck in customizing Free Swatch theme for my Website.

    When I try to use portfolio option in it, it displays all portfolio images above content for the portfolio item in my website.

    I want to remove these automated pics above the title of my page (as below that i can include gallery and post pics at my preferred place). Please help me with some way to fix it. ?

    Thanks in advance.

    Varun, I am having the same problem as you regarding this theme. Seems looking at your link that you have succeeded in removing the automated photos above the images in a portfolio page. Can you let me know how you did that?

    Thanks in advance.

    Hi Amy,

    Yes I did succeeded in removing the automated gallery pics on portfolio item page.
    For this, either modify below lines in style.css or add the same in custom.css (preferable, as this way you can easily manage the customizations).
    Note that below lines can vary from Swatch version to version, so prefer to copy similar looking lines from your style.css and copy it in custom.css and then modify width and height as 0 px in it.

    /* To disable automatic listing of gallery photos on portfolio item pages */
    body.single-portfolio #post-gallery, body.single-portfolio .post-embed, body.single-portfolio .video { float: left; margin-bottom: 0px; width: 0px; height: 0px }
    #post-gallery .pagination .jcarousel-prev, #post-gallery .pagination .jcarousel-next { cursor: pointer; width: 0px; height: 0px; position: absolute; top: 45%; }

    Hope it helps.





    I have a similar issue, the portfolio preview images are not loading for swatch portfolio page, when I open the developer console on chrome to debug this is the message :

    Failed to load resource: the server responded with a status of 400 (Bad Request)

    The screenshot is as follows :



Viewing 15 replies - 1 through 15 (of 27 total)
  • The topic ‘Customizing this Swatch theme…’ is closed to new replies.