Support » Plugin: Ultimate Member - User Profile & Membership Plugin » Customizing mail templates not possible

  • Hello guys,

    I’m using the latest UM version 2.0.4 and I’m not able to customize the mail texts, because the customized text will not be saved after saving the changes.
    Only the subject will be saved.
    Am I missing something?
    I already had a look at the permissions in the plugin directory, but they look fine to me.

    Thanks and regards
    Sebastian

Viewing 15 replies - 1 through 15 (of 15 total)
  • Just found this in the documentation

    https://docs.ultimatemember.com/article/121-using-html-in-e-mail-templates

    but it doesn’t work!

    What am I doing wrong?

    Can anyone please answer this? It seems a lot of people have this problem.

    This is the new email logic that was implemented in the UM2.0 release.

    In UM1, if you had edited an email template in wp-admin, it was overwritten with every update. In the UM2 release, custom email templates and UM default email templates are stored in different folders.
    – Default email notification templates are stored in “.. plugins/ultimate-member/templates/email”.
    – Edited/customized email notification templates are stored in “../themes/[theme_name]/ultimate-member/email”.

    In UM2 you can reset an email template to default by the deleting the current template from the “../themes/[theme_name]/ultimate-member/email” directory. The UM devs promise to make this a wp-admin visual process in a future release.

    I hope this helps.

    It still doesn’t work.

    For example I’ve created a file called ‘changedpw_email.html’, but it still takes the english version of the PHP file.

    What am I doing wrong?

    • This reply was modified 1 year, 4 months ago by  xenator.

    It works with the filname changedpw_email.php and HTML content within that file!

    Thanks for the support!

    Did you manage to find a list of files names for these e-mails? I’ve created some templates and loaded them however I don’t know what to call them all. There are only a couple in the templates folder.

    Check this out:
    https://docs.ultimatemember.com/article/1335-email-templates

    You will find the email template filenames in the folder “wp-content/plugins/ultimate-member/templates/email/”.

    • This reply was modified 1 year, 3 months ago by  evollo.

    I uploaded a new template to wp-content/themes/childtheme/ultimate-member/templates/email/checkmail_email.php but it does not change when the e-mails go out.

    If I upload the file in to wp-content/themes/childtheme/ultimate-member/email/checkmail_email.php this works. But will overwriting this file cause issues?

    I am also unable to call css styling in <head> tags and I need to call custom fonts – does anyone know how this is achieved?

    To style my email The only way I found was to do it with inline style like <div style=”font-family:….

    Does someone found how to add image/logo to the mail ? Since 2.X image are not working …

    lijitimit

    (@lijitimit)

    Just wanted to confirm @benmcmahon solution seemed to work.
    UM documentation seems incorrect: HERE.

    They want “templates” folder in the path but doesn’t seem to work:
    DOES NOT WORK: /public_html/wp-content/themes/twentyfifteen/ultimate-member/templates/email/MY-EMAIL-TEMPLATE.php

    WORKS: /public_html/wp-content/themes/twentyfifteen/ultimate-member/email/MY-EMAIL-TEMPLATE.php

    Hope that helps the next guy or gal!

    Hi, I have a same problem here. After change my settings, I try to save and the result it’s 404 error.

    Thanks a ton for this. Solution works for me and actually I got use to it…

    dionysios

    (@dionysios)

    Hello, Iam facing the same problem with emails. I can not change anything or enable/disable them. Can someone give me some help. I have tried changing template reset everything in my site and still nothing. All I got is this error:

    Forbidden

    You don’t have permission to access /wp-admin/admin.php on this server.

    Also I test it in localhost and works fine without issue. What is going on? Please HELP!

    I am having the same issue when try to disable the notification emails. Our membership does not require a majority of the notifications and they are sent when we don’t want them to be sent. I deselect the checkbox and Update, which only takes me to a “Page not Found” error message. When returning to the Email page in settings the email remains Enabled. Is is a server setting causing this. Thanks.

    clicks11

    (@clicks11)

    Disabling ModSecurity in cPanel (or asking your provider to disable it on the server if it is not present in cPanel) might help…

Viewing 15 replies - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.