Support » Plugin: Max Mega Menu » customizing doesn’t work at all

  • Resolved volkerforster

    (@volkerforster)


    Hi there,
    – I can’t either change the font size nor the layout from Flyout to Grid.
    – I can so far change the settings, but it never shows any effect on the website.
    – “Enable output of menu item descriptions” is unchecked, but all descriptions were shown. I had to delete them all.
    – Regardless the correct theme is selected it shows the message “This menu theme is not currently active as it has not been applied to any menu locations. You may wish to check you are editing the correct menu theme – you can choose a different theme to edit using the ‘Select theme to edit’ selector above. Alternatively, to apply this theme to a menu go to Appearance > Menus > Max Mega Menu Settings and select this theme from the ‘Theme’ dropdown.”

    As nice as this plugin is, and as much I already like it, I just have no chance to customize any settings. I can only use out of the box.

    I want to have a grid view with categories and subcategories, but it currently only shows the flyout. Please check yourself.

    Thank you.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author megamenu

    (@megamenu)

    Hi volkerforster,

    Thanks for posting a link. I’ve checked your site and the main menu isn’t currently being controlled by Max Mega Menu (it is your standard theme menu). Please can you enable MMM so I can see how far you have got?

    Regards,
    Tom

    I see. I don’t know why it never enabled, I ticked the checkbox several times and saved it yesterday, but after leaving and coming back to the menu settings, the checkbox was always unticked again. So I finally expected the function of the “enable” checkbox to be only to enable the menu item specific settings.

    Now I ticked the checkbox again, and saved the setting, and bang, the menu is there.

    Great.

    Thank you.

    Plugin Author megamenu

    (@megamenu)

    Hi volkerforster,

    The forum index is saying you’ve replied to this topic, but I don’t see any posts. I’m not sure what has happened there.

    I’ve checked your site and I can see you’ve enabled MMM. I also see the sub menu is configured as a grid layout, so that seems to be working.

    I also see you’re using a caching plugin. Caching plugins prevent changes on the server from making it to the browser (until the cache expires), sometimes making it appear as if things aren’t working as they should. It would be best to completely disable the caching plugin whilst you are making changes to the site, then only re-enable it once you have finished.

    Regards,
    Tom

    Plugin Author megamenu

    (@megamenu)

    Hi volkerforster,

    The forum index is saying you’ve replied to this topic, but I don’t see any posts. I’m not sure what has happened there.

    Ironically.. I can now see your reply. That will be because the wordpress.org forums were caching something.

    From what you’re describing, it sounds like your server has a layer of caching (a ‘deeper’ layer than a plugin), maybe memcache or redis. If it happens again, log into your hosting control panel and make sure those caches are cleared.

    Regards,
    Tom

    @megamenu
    You are right, my answer is not shown here – must be a hiccup on WordPress website.

    So I will try again:

    I wasn’t able to save the ticked “enable” checkbox, it always was turned off again as soon I left the page. This morning I tried again, and now the checkbox stay ticked, and the menu appears exactly as I wanted.

    Thanks a lot.

    Volker

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘customizing doesn’t work at all’ is closed to new replies.