Support » Theme: Astra » Customizer not working and latest Astra fail installing

  • Hi!
    I recently updated WP to 5.8 and customizer stopped working.

    Updated Astra from Themes and then I got the Critical error message on WP and my website down.

    I’m currently using “PHP v7.4 FPM”, moved to “PHP v7.4” but it wasn’t helpful. I also tried to update Astra almost three times, but I got always the same error. The only solution I found was restore a backup (I made one just before updating the last time) and go back, but customizer is still broke. I read that the latest Astra version fix it but I can’t install this one.

    Can anyone help me?

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hello @jeredemartino

    Sorry for the inconvenience!

    Can you share the critical error message so that we can take a look and get back to you?

    Do ensure you have the latest version of the Astra theme, WordPress 5.8 and PHP 7.4 or above.

    If the issue still persists, do share the error message so that we can help you out accordingly.

    Looking forward to hearing from you.

    Thread Starter jeredemartino

    (@jeredemartino)

    I’ll try that plugin, but I don’t understand how it helps. Can you tell me more?

    About the Error message: “Ha habido un error crítico en esta web. Por favor, comprueba la bandeja de entrada del correo electrónico del administrador de tu sitio para obtener instrucciones.” (TRANSLATED: There has been a critical error on this website. Please check your site administrator’s email inbox for instructions. )

    I made a staging version of my web and tried there uploading the latest astra (not updated from wp dashboard, I loaded a zip this time) and error persist.

    Thread Starter jeredemartino

    (@jeredemartino)

    The plugin ( https://wordpress.org/plugins/classic-widgets ) works. The problems updating Astra still there, but at least I can use Peronalizer again. Thanks a lot!

    I’m in contact with Astra team, so I hope we can find a solution to the updating fail.

    [Edit] Last time I tried updating Astra I got this info by WP on my Inbox:

    WordPress versión 5.8
    Tema actual: Astra – Child (versión 2.6.0)
    Plugin actual: (versión )
    PHP versión 7.4.16

    Detalles del error
    ==================
    Se ha producido un error del tipo E_ERROR en la línea 449 del archivo /home/c2270225/public_html/qdg-stagin/wp-content/themes/astra/inc/extras.php. Mensaje de error: Uncaught Error: Class ‘Astra_Icons’ not found in /home/c2270225/public_html/qdg-stagin/wp-content/themes/astra/inc/extras.php:449
    Stack trace:
    #0 /home/c2270225/public_html/qdg-stagin/wp-content/themes/astra-child/functions.php(90): require_once()
    #1 /home/c2270225/public_html/qdg-stagin/wp-settings.php(546): include(‘/home/c2270225/…’)
    #2 /home/c2270225/public_html/qdg-stagin/wp-config.php(113): require_once(‘/home/c2270225/…’)
    #3 /home/c2270225/public_html/qdg-stagin/wp-load.php(50): require_once(‘/home/c2270225/…’)
    #4 /home/c2270225/public_html/qdg-stagin/wp-admin/admin.php(34): require_once(‘/home/c2270225/…’)
    #5 /home/c2270225/public_html/qdg-stagin/wp-admin/themes.php(10): require_once(‘/home/c2270225/…’)
    #6 {main}
    thrown

    I also tried installing Astra 3.6.4 and problems persists.

    • This reply was modified 2 months, 1 week ago by jeredemartino. Reason: Add information about the Critical Error

    Hi @jeredemartino,

    I noticed that your opened ticket had already been answered by our agent but you haven’t replied to it. Please kindly reply to the ticket if you still need any assistance from us.

    Kind regards,
    Herman 🙂

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.