Support » Plugin: One Click Demo Import » Customizer import doesn’t show up on frontend

  • Resolved Václav Greif

    (@vasikgreif)


    When I import customizer file, the changes show up correctly on backend, but they don’t appear on frontend. I have to change some setting and re-save customizer for the changes to appear on frontend.

    Any chance to fix this?

Viewing 11 replies - 1 through 11 (of 11 total)
  • Hi,

    we are using this customizer imports on a few themes and it works ok (it applies the customizer changes to the backend as well as on the frontend).

    What kind of customizer settings are not working for you (maybe custom controls, or basic input texts, image controls,…?)?

    Are any of the imported customizer settings displaying on the frontend? Or are all imported customizer settings not applied to the frontend?

    Take care!

    Hello, some settings are applied to the frontend, some are not (like background colors).

    Hi,

    All colors should import ok, I tested this on the default WP theme Twentyfifteen theme as well. I’ve set the background color to yellow and made an export of that site’s customizer. Then I imported it on a clean WP site with Twentyfifteen theme and it imported ok.

    I this plugin (OCDI) we are using the Customizer Export/Import plugin code: https://wordpress.org/plugins/customizer-export-import/, so I would advise you to install this plugin and make a manual import of the customizer file and see if everything imports ok, or is the resault the same as with our plugin.

    Take care!

    I tested the plugin, and yes, that works great, I can see the changes. When using OCDI, the changes are not applied..:(

    Hmmm, that’s strange…

    It would be perfect, if you could send me the theme and the customizer import file, so I can test it out. Could you do that? My email is the same as my username here + (at gmail.com).

    Take care!

    I found the issue by checking the code of the Customizer import export plugin.

    Readding the

    do_action( 'customize_save_after', $wp_customize );

    into class-ocdi-customizer-importer.php fixed the issue.

    Hi,

    thanks! That’s what I would test…

    I’ll update the plugin this weekend and I would ask you, if you would be so kind and test it again, when I update it?

    Take care!

    Hi,

    the $wp_customize in our plugin was always set to null, so it couldn’t have solved your issue.

    I’ve now fixed that, but setting the parameter wp_customize=on for our AJAX call (which is needed to have a valid $wp_customize global present and usable), is causing other issues for widgets import. I’ve looked at the WP core and couldn’t find a quick solution, so I will have to look at this a bit closer or find another solution next week.

    Just wanted to let you know, that the update will not be available this weekend.

    Take care!

    Hi,

    just a quick update.

    I’ve solved this issue, but it will be available in the next version -> 2.0 (probably next week). I’ve added a seperate customizer import AJAX request with the wp_customize set to ‘on’ and that solved the issue nicely.

    Take care!

    Hi,

    we are close to the 2.0.0 release and I would kindly ask you, if you could test the customizer import with this 2.0.0 Release candidate version of the OCDI plugin: https://dl.dropboxusercontent.com/u/14641788/OCDI/one-click-demo-import-2.0.0-RC.zip

    There are some other features, but for this bug report no changes are needed. Please just test it out with this version and let me know, if the issue is fixed.

    Take care!

    Hi,

    just another update. In the latest release candidate: https://dl.dropboxusercontent.com/u/14641788/OCDI/OCDI-v2.0.0-RC3.zip and in the official update which should come out tomorrow, I’ve removed the customize_save* WP customzier action hooks by default, if anyone wants them to be enabled, please add this to your themes:

    add_action( 'pt-ocdi/enable_wp_customize_save_hooks', '__return_true' );

    Take care!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Customizer import doesn’t show up on frontend’ is closed to new replies.