Support » Theme: One Page Express » Customizer Never Loads When Child Theme Activated

  • With a child theme activated the customizer simply never loads. It just hangs with the message ‘Please wait, this might take a little while’.

    Is there any way to resolve this?

Viewing 11 replies - 1 through 11 (of 11 total)
  • Hello,

    We made an update to the free theme, companion plugin and the pro theme. Please go to siteurl/wp-admin/update-core.php?force-check=1 and see if any updates are available

    If there are, proceed with all the updates. You should have the Plugin, FREE and PRO theme updated ( FREE : 1.0.9, PLUGIN : 1.0.6, PRO : 1.0.2 ).

    [ Signature moderated ]

    • This reply was modified 2 years, 8 months ago by Jan Dembowski.

    Many thanks Ionut.

    I just checked for the updates as requested, but my WordPress installation is not giving me any updates for the free theme or the companion plugin. Will they take a while to come through?

    The existing version of the free theme I have is 1.0.9.

    The existing version of the companion plugin I have is 1.0.6.

    The versions you have mentioned in your response above are the existing versions with which the customizer issue exists. Have you updated beyond these versions?

    • This reply was modified 2 years, 8 months ago by Salpetriere.

    I have the same problem. I use the versions @ionuttudose suggested in his post. Problem is still there.

    Hopefully you find a solution, since I like the theme very much and want to use it.

    I contacted Ionut directly using the contact form on his site here – http://onepageexpress.com/#support

    The issue hasn’t been resolved yet, but Ionut has responded to me using that contact method. Perhaps you could get in touch with him that way?

    Inout has confirmed that there are no newer versions of the theme/plugin than those mentioned in his response above.

    The problem is however that the issue still exists within these versions. Ionut if we could get this resolved at your best convenience it would be greatly appreciated.

    @salpetriere, thank you for your reply. I will get in contact directly and when there is a breaktrough I will let you know.

    Ionut has now responded to me. He says that the theme does not work with a child theme.

    He says that the only child theme that works with it is the premium theme – https://imgur.com/a/Ant8D

    I’ve asked him if he could allow the theme to work with child themes but he has not responded to that enquiry.

    • This reply was modified 2 years, 8 months ago by Salpetriere.

    If this is the case, it would be a shame. I want to change some small things and it is always better to use a child theme then overwrite css. But if it turns out to that, then I will do it like that.

    The fact that the theme has been built to disallow child themes contravenes the WordPress theme development guidelines – https://make.wordpress.org/themes/handbook/review/required/#core-functionality-and-features

    Ionut has however provided me with a child theme that should work (I haven’t tested it yet), add the following to your child themes functions.php file.

    add_filter('cloudpress\customizer\supports', "__return_true");
    add_action('wp_enqueue_scripts', function () {
    	wp_enqueue_style('one-page-express-style', get_template_directory_uri() . "/style.css" );
    });

    I believe this should replace any existing action enqueuing the parent theme style.css

    It looked like it worked….
    I added the script to functions.php and after that I could use the customizer 🙂 Unfortunately I could not save and publish the changes made 🙁
    I will try further and keep you updated.

    Sorry, I was to quick…… Can’t delete my post, so that’s why I edited it to this….

    • This reply was modified 2 years, 8 months ago by mvalbracht.

    In my previous post I was happy since I got it working. But I cheered to early. I wanted to delete the post because I published code that wasn’t correct in it. I couldn’t delete the post and that’s why I just changed it to some text.

    I tried several things but for me it still doesn’t work how it should. Yes, I can work in the customizer but it doesn’t work properly.
    – The save & publish button stays like that even when clicked. But…. sometimes it does save & publish the changes but most of the times not.
    – The media library keeps loading.
    – I added a background photo which should be displayed behind the contact form but it is gone. Although I can see in the “menu” of the customizer that it is selected.
    – Maybe there is more but I stopped testing.

    Overall I can’t rely on the correct working of the child theme so I won’t use it. I will reconsider to make my changes with custom css or maybe change theme at all. The last would be a shame since I really like it.

    • This reply was modified 2 years, 8 months ago by mvalbracht.
Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Customizer Never Loads When Child Theme Activated’ is closed to new replies.