Support » Fixing WordPress » Customizer gives a 403 error

  • After updating wordpress to 5.0 my customizer gives a 403 error. Before I already had problems with it. I couldn’t edit my widgets, footer 1 and footer 2. Here is some information that might be interesting. It’s a child theme I made from the twenty seventeen theme.The twenty seventeen theme is fully updated. I read that it could be a plugin conflict. So I did deactivated all of them, but that didn’t help. Switching to the parent theme didn’t help either. I asked the hosting provider, if it had anything to do with security settings. So they checkt and changed something, but that didn’t work. Anyone able to help? Thank you in advance.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • It might be because of corrupt .htaccess file.
    You generate a fresh .htaccess file by logging into your WordPress admin area and going to Settings ยป Permalinks page
    Simply click on the Save Changes button at the bottom of the page and WordPress will generate a fresh .htaccess file.

    Hmm, it’s strange that you’re still seeing the issue after activating the parent theme and deactivating all plugins. Have you tried the new Twenty Nineteen theme yet to see if the problem is still there with that theme?

    If even that theme still has the problem, try to install “Health Check”: https://wordpress.org/plugins/health-check/ On the troubleshooting tab, you can click the button to disable all plugins and change the theme for you, while you’re still logged in, without affecting normal visitors to your site.

    If you still see an issue, my only other recommendation is to try downloading WordPress again, accessing your server via SFTP or FTP, or a file manager in your hosting account’s control panel, and deleting then replacing your copies of everything except the wp-config.php file and the /wp-content/ directory with fresh copies from the download. Hope these suggestions help!

    Thanks for the fast reaction, I will check this out and let you know if it works ๐Ÿ™‚

    I made a back-up of the website and rebuild it in a clean wordpress 5.0 on my localhost. Then I found out the problem occurred when uploading the data from the database. This is when the problem occurred. Any idea what could’ve caused it? Saved the permalinks settings; didn’t work. Tried the health check with the trouble shooting mode; didn’t work. Thank you in advance.

    • This reply was modified 1 year, 7 months ago by cisisnew.
Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Customizer gives a 403 error’ is closed to new replies.