Support » Plugin: External Links - nofollow, noopener & new window » Customizer constantly refreshing (Generatepress Theme)

  • mexl

    (@mexl)


    Hi,
    when using the default customizer on generatepress together with WP External Links, the Customizer loops/refreshes all the time.
    Deactivating WP External Links solves the problem.

    Thank you for the great plugin, we love it! Any help is highly appreciated,
    Matt

    The console reports:
    Uncaught Error: react-modal: No elements were found for selector #wprm-admin-modal.
    at c (admin-modal.js:92)
    at Object.t.setElement (admin-modal.js:92)
    at Function.value (admin-modal.js:92)
    at Object.<anonymous> (admin-modal.js:92)
    at Object.<anonymous> (admin-modal.js:92)
    at n (admin-modal.js:1)
    at Module.<anonymous> (admin-modal.js:92)
    at Module.<anonymous> (admin-modal.js:92)
    at n (admin-modal.js:1)
    at admin-modal.js:1
    customize.php?return=%2Fwp-admin%2Fadmin.php%3Fpage%3Dwpel-settings-page%26tab%3Dsupport:3565 Uncaught ReferenceError: ncoreJQ is not defined
    at customize.php?return=%2Fwp-admin%2Fadmin.php%3Fpage%3Dwpel-settings-page%26tab%3Dsupport:3565
    customize.php?return=%2Fwp-admin%2Fadmin.php%3Fpage%3Dwpel-settings-page%26tab%3Dsupport:4777 Uncaught ReferenceError: ncoreJQ is not defined
    at customize.php?return=%2Fwp-admin%2Fadmin.php%3Fpage%3Dwpel-settings-page%26tab%3Dsupport:4777
    customize.php?return=%2Fwp-admin%2Fadmin.php%3Fpage%3Dwpel-settings-page%26tab%3Dsupport:4974 Uncaught ReferenceError: ncoreJQ is not defined
    at customize.php?return=%2Fwp-admin%2Fadmin.php%3Fpage%3Dwpel-settings-page%26tab%3Dsupport:4974
    customize.php?return=%2Fwp-admin%2Fadmin.php%3Fpage%3Dwpel-settings-page%26tab%3Dsupport:5165 Uncaught ReferenceError: ncoreJQ is not defined
    at customize.php?return=%2Fwp-admin%2Fadmin.php%3Fpage%3Dwpel-settings-page%26tab%3Dsupport:5165
    customize.php?return=%2Fwp-admin%2Fadmin.php%3Fpage%3Dwpel-settings-page%26tab%3Dsupport:5357 Uncaught ReferenceError: ncoreJQ is not defined
    at customize.php?return=%2Fwp-admin%2Fadmin.php%3Fpage%3Dwpel-settings-page%26tab%3Dsupport:5357
    customize.php?return=%2Fwp-admin%2Fadmin.php%3Fpage%3Dwpel-settings-page%26tab%3Dsupport:5497 Uncaught ReferenceError: ncoreJQ is not defined
    at customize.php?return=%2Fwp-admin%2Fadmin.php%3Fpage%3Dwpel-settings-page%26tab%3Dsupport:5497
    customize.php?return=%2Fwp-admin%2Fadmin.php%3Fpage%3Dwpel-settings-page%26tab%3Dsupport:5621 Uncaught ReferenceError: ncoreJQ is not defined
    at customize.php?return=%2Fwp-admin%2Fadmin.php%3Fpage%3Dwpel-settings-page%26tab%3Dsupport:5621
    customize.php?return=%2Fwp-admin%2Fadmin.php%3Fpage%3Dwpel-settings-page%26tab%3Dsupport:5839 Uncaught ReferenceError: ncoreJQ is not defined
    at customize.php?return=%2Fwp-admin%2Fadmin.php%3Fpage%3Dwpel-settings-page%26tab%3Dsupport:5839

    • This topic was modified 2 weeks ago by mexl. Reason: Added error

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author WebFactory

    (@webfactory)

    Hi,
    Sorry to hear you’re having problems!

    Thank you for the detailed report. We’re looking into the issue.

    mexl

    (@mexl)

    Thank you, if you require any assistance or more info just let me know. It happens on two of our domains with the same setup.
    All the best,
    Matt

    Plugin Support Alexandru Tapuleasa

    (@talextech)

    Hi,

    We’ve looked into this but so far couldn’t reproduce it ( you can see how it behaves with Generatepress in this recordning: https://screencast-o-matic.com/watch/cqXjqUUQMJ )

    Could you copy/paste the Technical Info from the Support tab of the External Links Settings page? Maybe it’s a combination of plugins that is causing the issue, not just External Links on it’s own.

    mexl

    (@mexl)

    Dear Alexandru,
    thank you for the follow up. It happens on two domains out of 4.
    The two not working BOTH have these plugins (which the other two domains do not have):
    – Loco Translate
    – Nav Menu Roles

    Here is the tech info (without domain names):

    
    WordPress-Version:  5.2.4
    PHP-Version:  7.3.11
    Aktivierte Plugins:
     - AAWP, version: 3.9.3
     - Affiliate Butler Pro, version: 2.1.15
     - All-in-One WP Migration, version: 7.9
     - All-in-One WP Migration Unlimited Extension, version: 2.32
     - Asgaros Forum, version: 1.15.2
     - Better Search Replace, version: 1.3.3
     - Classic Editor, version: 1.5
     - Code Snippets, version: 2.13.3
     - Contextual Related Posts, version: 2.7.0
     - Delete Me, version: 2.8
     - Disable Comments, version: 1.10.2
     - Disable Gutenberg, version: 1.9
     - Easy Table of Contents, version: 1.7
     - Embed Plus for YouTube - Gallery, Channel, Playlist, Live Stream, version: 13.1.2.1
     - Enable Media Replace, version: 3.3.6
     - GP Premium, version: 1.8.3
     - Image Source Control, version: 1.10.2
     - Imagify, version: 1.9.7
     - Lightweight Social Icons, version: 1.0.1
     - List category posts, version: 0.81
     - Loco Translate, version: 2.3.1
     - MainWP Child, version: 4.0.3
     - Nav Menu Roles, version: 1.9.5
     - NinjaFirewall (WP Edition), version: 4.0.4
     - Redirection, version: 4.4.2
     - Revive Old Posts, version: 8.4.4
     - Revive Old Posts Pro Add-on, version: 2.2.6
     - Shariff Wrapper, version: 4.6.3
     - Statify, version: 1.6.3
     - Statify Widget: Popular Posts, version: 1.2.5
     - Statify – Extended Evaluation, version: 2.6.0
     - Thrive Architect, version: 2.4.4.2
     - Thrive Leads, version: 2.2.5.2
     - Thrive Product Manager, version: 1.2.1
     - UpdraftPlus - Backup/Restore, version: 1.16.20
     - User Registration, version: 1.7.3
     - Widget Shortcode, version: 0.3.4
     - WP External Links, version: 2.35
     - WP Last Modified Info, version: 1.6.1
     - WP Rocket, version: 3.4.1.2
     - WP Show Posts, version: 1.1.3
     - WP Show Posts Pro, version: 1.0-beta.2
     - WP Sitemap Page, version: 1.6.2
     - Yoast SEO, version: 12.4
    
    WP External Links - Einstellungen:
    array(
    'wpel-external-link-settings' => array (
      'apply_settings' => '1',
      'target' => '_blank',
      'target_overwrite' => '1',
      'rel_follow' => 'nofollow',
      'rel_follow_overwrite' => '1',
      'rel_noopener' => '1',
      'rel_noreferrer' => '1',
      'rel_external' => '1',
      'title' => '{title}',
      'class' => '',
      'icon_type' => '',
      'icon_image' => '1',
      'icon_dashicon' => 'dashicons-menu',
      'icon_fontawesome' => 'fa-500px',
      'icon_position' => 'right',
      'no_icon_for_img' => '1',
    ),
    'wpel-internal-link-settings' => array (
      'apply_settings' => '1',
      'target' => '_self',
      'target_overwrite' => '1',
      'rel_follow' => 'follow',
      'rel_follow_overwrite' => '1',
      'rel_noopener' => '',
      'rel_noreferrer' => '',
      'title' => '{title}',
      'class' => '',
      'icon_type' => '',
      'icon_image' => '1',
      'icon_dashicon' => 'dashicons-menu',
      'icon_fontawesome' => 'fa-500px',
      'icon_position' => 'right',
      'no_icon_for_img' => '1',
    ),
    'wpel-excluded-link-settings' => array (
      'apply_settings' => '1',
      'target' => '_blank',
      'target_overwrite' => '1',
      'rel_follow' => 'follow',
      'rel_follow_overwrite' => '1',
      'rel_noopener' => '1',
      'rel_noreferrer' => '1',
      'title' => '{title}',
      'class' => '',
      'icon_type' => '',
      'icon_image' => '1',
      'icon_dashicon' => 'dashicons-menu',
      'icon_fontawesome' => 'fa-500px',
      'icon_position' => 'right',
      'no_icon_for_img' => '1',
    ),
    'wpel-exceptions-settings' => array (
      'apply_all' => '1',
      'apply_post_content' => '1',
      'apply_comments' => '1',
      'apply_widgets' => '1',
      'skip_post_ids' => '',
      'ignore_classes' => '',
      'subdomains_as_internal_links' => '',
      'include_urls' => '',
    
    • This reply was modified 1 week ago by mexl.
    • This reply was modified 1 week ago by Marius L. J.. Reason: Fix formatting
    Kratos

    (@politicske)

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.