Support » Themes and Templates » Customize/Live Preview not working

  • It will open the sidebar, but not my blog. Therefore not only can I not live preview anything, but also can not customize, including the theme I have been using for some time. It is almost as though it keeps looping when trying to contact my blog. Does anyone know what is going on?

Viewing 15 replies - 16 through 30 (of 36 total)
  • Chrome (Mac) is my normal browser. The issue is not browser specific for me.

    BTW, thanks for all the effort you’re putting in on this issue.

    Hi Davey, please look at the mentioned ticket, I posted my solution there. You can try this until the next version is coming out.

    Bit confused.

    // Check for a signature in the request.
    index = response.lastIndexOf( signature );
    if ( -1 === index || index < response.lastIndexOf(‘<body>’) ) {
    deferred.rejectWith( self, [ ‘unsigned’ ] );
    return;
    }

    // Strip the signature from the request.
    response = response.slice( 0, index ) + response.slice( index + signature.length );

    // Create the iframe and inject the html content.
    self.iframe = $(‘<iframe />’).appendTo( self.container );

    is where? I didn’t see it where I assumed you were pointing at.

    Ah… I found it (where you said it was, of course), but the fix you suggested didn’t work for me. I tried the <body> fix first, then backed up to the //return. Thanks though. Seriously, your kung fu is better than mine!

    I used the script debug, so the customize-controls.js was used by WP. Did you already used the body tag instead of html in the customize-controls.min.js, too? That’s usually used by WP. Thanks! So let’s keep on fighting 😉

    anahata9

    (@anahata9)

    So… I assume from the way this was left that there is still no solution to this?
    Everything was fine, then live preview stopped working. Left sidebar visible, but nothing in main window.
    All I can think that changed was I installed some new themes and activated Akismet. I have since deactivated Akismet (which means getting lots of spam now), but no change.
    I have opened it in Firefox and Chrome. Doesn’t work in either browser.
    So sad… until this point I was so thrilled with WordPress.
    Now this major part of its functionality is disabled!!!
    If I uninstall and reinstall WordPress, what will be lost in the process? (anyway, I’m not sure it will make a difference based on comments above)

    Fee

    (@wdfee)

    Hello anahata9, please look into the linked ticket on WordPress trac.
    For me nacins solution from this ticket works:
    http://core.trac.wordpress.org/ticket/22430

    … try this one-line plugin on for size:
    remove_action( 'shutdown', 'wp_ob_end_flush_all', 1 );

    I won’t suggest to make a new install now because WP 3.5 is coming out very soon!

    anahata9

    (@anahata9)

    If possible, could you explain in terms a kindergarten child would understand. Where would I put that code?

    Fee

    (@wdfee)

    🙂 sure, sorry. I hope, my English will be understandable.
    First: Do you have access to your files per FTP? You will need this.

    Do you use an own theme? If yes you could put it in the functions.php

    If not do this:
    Open a text editor like notepad and put this into it:

    <?php
    /*
    Plugin Name: My Custom Plugin (any name you like..., must be unique)
    Author: Your Name
    Version: 1.0
    Description: Customizer Bug Solution (You can write what you want here)
    */
    remove_action( 'shutdown', 'wp_ob_end_flush_all', 1 );
    ?>

    Then save this file into your plugins directory: Look for “wp-content” inside your installation and there for the folder “plugins”. Save the file into this folder (save it on your computer first and then load it up per FTP) and name it “mycustomplugin.php” (be sure that it doesn’t have another suffix/ending and that this name is unique).
    O.k. Now open your WordPress site in a browser, login and activate the Plugin on your plugins page.

    Please give me feedback if you got it and if it’s working for you!

    anahata9

    (@anahata9)

    Thanks very much. Unfortunately, it didn’t work.

    Fee

    (@wdfee)

    in the last hour WordPress 3.5 has been released. Maybe you’ll have luck with updating and / or making a new install now.

    anahata9

    (@anahata9)

    Updated to 3.5. Still doesn’t work. 🙁

    Fee

    (@wdfee)

    ok, let’s step back a bit.
    Did you try deactivating all plugins and switching to a default theme (twentyeleven for example)? Clearing cache?
    Do you have special configurations in your htaccess? Are you on a multisite install?
    Is it a live site or can you test a little bit?
    If it’s live – can you give us the link?
    Did you try firebug yet?

    davey.leslie@gmail.com

    (@daveylesliegmailcom)

    I just updated to 3.5 and still having the same old problems. I’ve tried everything suggested on the forum, and nothing. I still love WordPress, but this is annoying.

    anahata9

    (@anahata9)

    Thanks. I deactivated and even deleted all plugins. Switched to twenty eleven. Cache is empty.
    No special configurations. I don’t have multisite install.
    It is live, but in development and nobody is probably visiting it, so you can look at it HERE.
    didn’t try firebug. i’ll look into it

Viewing 15 replies - 16 through 30 (of 36 total)
  • The topic ‘Customize/Live Preview not working’ is closed to new replies.