WordPress.org

Support

Support » Themes and Templates » Customize/Live Preview not working

Customize/Live Preview not working

  • It will open the sidebar, but not my blog. Therefore not only can I not live preview anything, but also can not customize, including the theme I have been using for some time. It is almost as though it keeps looping when trying to contact my blog. Does anyone know what is going on?

Viewing 15 replies - 1 through 15 (of 36 total)
  • Same problem here. Different browsers, deactivating plugins… no effect.

    Hi I am having the same issue as well. Did anyone resolve this?

    Everything was working fine and all of a sudden this issue started to occur. I don’t know if it is due to the latest update as I keep my wordpress updated whenever it calls for it. I would really appreciate if someone could revert as this is causing a a lot of delay in my project.

    Thanks.

    Problem persists under 3.4.2

    Hi I solved the issue by doing the following:

    – Re-installed wordpress in my cpanel. that was the last resort for me as I had been running around in circles trying to deactivate even uninstall plugins, deleting media library, rolling back the wordpress versions and everything in between to no avail. After losing several precious hours over this, I finally decided to take the plunge as I was not getting anywhere anyway. So I uninstalled wordpress in my cpanel (I use Hostgator) and re-installed it. After that I re-uploaded my premium theme and everything was fixed.

    So if you are all still struggling with this issue, you may have to make a decision. Note that I did not risk much as my site was at its infancy. Therefore, for me it was the best route.

    Yikes. Not worth it, I guess. But thanks.

    For what it’s worth, this is what Live Preview is generating on my sites:

    <div id=”customize-preview” class=”wp-full-overlay-main”></div>

    An empty div.

    Can you please send a hint which this theme is from the same vendor or different.. because many a times they do have a tagged points where it clutches the plugin mode writes in admin editor.. which we can’t see its a background process.. and yeah the version you shown here is very buggy!!

    Thanks!
    [ sig removed ]

    Twenty Twelve, though same problem with Twenty Eleven

    same problem here.
    Interesting: it works on my local server but not on the remote live site. Files and database dump are completely the same (except server path and tld of domains). There are php errors on the domain mapped subsites, but not on the main site (and there the customizer doesn’t work, too, on remote server).

    Didn’t want to reinstall yet, because I’ve a running multisite network. But I tried reuploading the WordPress core files (and deleting old ones first) from current version 3.4.2, I did a database dump switch to a new database. and of course first deactivating all plugins, switching between integrated (Twenty Eleven) and own themes. didn’t help.

    I installed a clean copy with a new database and am getting the same empty div. I admin several sites though a dedicated server (jtlnet) running CentOS and the same problem exists for all of the different sites. I’m starting to wonder if this is a server-related issue. Don’t really want to think about that… yikes.

    Difference between my local and remote server:
    Local: Apache/2.2.22, PHP/5.3.15
    Remote: Apache/2.2.21, PHP/5.3.10
    I’m no server freak and remote on a managed server. Could you give me a hint where to look at?

    I compared local and remote page loading of customizer with firebug and phpinfo, using Twenty Eleven. In Memory Profile (firebug console) the local customize.php does 13167 calls, the remote only 10016 calls.
    I didn’t work much with the memory profile before, it’s a little bit hard to compare… If I sort by loaded files I can say that some files listet on local are not listet on remote. But in firebug Net everything is loaded ok.

    In addition I have to say, that I renamed wp-content. If you did that renaming, too, we could give that a deeper look if it could cause conflicts.

    in class-wp-customize-manager.php the scripts are not enqueued.
    if I comment out this function (#684) or the belonging action hook
    add_action( 'customize_controls_enqueue_scripts', array( $this, 'enqueue_control_scripts' ) );
    on my running local install, the result is completely the same as on remote (empty div, missing scripts):

    public function enqueue_control_scripts() {
    		foreach ( $this->controls as $control ) {
    			$control->enqueue();
    		}
    	}

    I haven’t seen this way of enqueuing in WordPress before. And it doesn’t make sense why this should be differently handled by servers.
    I think I’ll open a ticket maybe.

    I actually have no idea what could cause the empty div. Not a clue, and it’s maddening because very few people seem to be experiencing this and the issue is way off the radar screen, it would seem. It makes no sense to my pointy little brain.

    I hope to get insights on wordpress.org – maybe you want to join in the ticket, where somebody reported this as bug:
    http://core.trac.wordpress.org/ticket/22037

    Hi Davey, could you please check this: The preview in customizer is working for me when using Google Chrome Browser. Maybe you’re more advanced than me in javascript analysing and could check it. I think it’s an jquery issue.

Viewing 15 replies - 1 through 15 (of 36 total)
  • The topic ‘Customize/Live Preview not working’ is closed to new replies.
Skip to toolbar