Support » Plugin: MailPoet - emails and newsletters in WordPress » Customize Your Unsubscribe Page not working

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support dromero20

    (@dromero20)

    Hi!

    Please note that If you preview your custom Unsubscribe page on the Edit Page screen, the shortcode won’t render. Please use the Preview buttons above or test with Unsubscribe links in actual emails instead.

    You can find the preview link in MailPoet -> Settings -> Basics – you can also share that link with us here, so we can take a look and confirm if it renders.

    Have a nice day!

    Thread Starter deindorfleben

    (@deindorfleben)

    Dear dromero20,

    Thank you for your reply.

    I have tested your suggestion and if I use standard Mailpoet unsubscribe page in MailPoet -> Settings -> Basics, then it renders the shortcode.

    But I would like to use the short code a separately created page. In this page the shortcode does not render: Test

    I have inserted shortcode “[mailpoet_manage text=”Manage your subscription”]” for registered user accounts on the same page, and this works fine.

    Unfortunately only shortcode “[mailpoet_page]” does not render…

    Would appreciate your help, thank you!

    Plugin Support dromero20

    (@dromero20)

    Hi, @deindorfleben!

    The code only renders by following the link on an already-sent email or by using the “Preview” link in MailPoet -> Settings -> Basics.

    So what you’d need to do is assigning your custom page in “Basics”, save the changes and then click on “Preview”. Does the shortcode of your custom page render if you click on “Preview”? If it does, then it’s working correctly.

    Thread Starter deindorfleben

    (@deindorfleben)

    Great – now it works, thank you!

    Plugin Support dromero20

    (@dromero20)

    Awesome! No problem!

    Have a nice day!

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.