Support » Theme: Twenty Seventeen » Customize tool not saving changes

  • Resolved micahnova

    (@micahnova)



    I selected the twenty seventeen theme, but cannot get the customize tool to save any changes that I’m making. After I click save & publish, I click to close the customize window and get the message “This page is asking you to confirm that you want to leave – data you have entered may not be saved” every time. Any changes I make are lost. What obvious thing am I doing wrong?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Hmmm odd. It sounds like something might be causing a conflict; usually it’s a plugin. Even though you said you clicked on the “Save & Publish” button, after you do that, is the button text greyed out and says “Saved“? Sometimes when I’ve clicked on it, I thought it was a successful click, but end up clicking it again.

    If it’s a plugin conflict, did you install any additional plugins?

    I’ve deleted all plugins just to be sure, and no, I still can’t get the “Save & Publish” button to actually save and publish.It shows a little animated circle rotating, and then the Save and Publish button just comes right back (not grayed out).

    Possibly related, but may also be unrelated… the customize tool is not allowing me to crop photos. In the customize area of wordpress, it will say, “There was an error cropping your image” every time no matter what image I select and for any purpose. In this instance, I don’t need to crop the header photo since it is already 2000 x 1200, so I just bypass it by opting to skip the cropping. Regardless, I cannot get Save & Publish to actually publish the new header image.

    Sounds like something is corrupted somewhere…not sure what though, and this is the Twenty Seventeen theme you are using and not a modified version of it right?

    One way to find out if it’s the theme or if it’s WordPress is to switch to a different default theme like Twenty Sixteen. Test the customizer and if that works, then switch back to twenty seventeen. If you encounter the same problem going back, then you may need to delete the twenty seventeen theme and reinstall it.

    Okay, I tried that with the same result. Gives me errors when attempting to crop images, and won’t save and publish.

    If the issue happens on another theme, then it appears it’s going to be related to your installation of WordPress, or even possibly something with the host server. I did a quick look in Google and found:

    https://wordpress.org/support/topic/wordpress-customizer-save-and-publish-to-saved-status-hanging/

    Not sure if that might be the issue for you, but a few questions for you:

    1. Was everything working before and if so, at what point did this issue start?
    2. Did you make any modifications to the theme?
    3. Does your site currently have content in it and do you have a method to backup?
    4. When you make changes in the customizer, do you see the changes take effect in the preview window?

    1. Yes, before I updated to wordpress 4.8 (is there a way to re-install?)
    2. no
    3. yes
    4. yes

    I’ve re-installed wp 4.8, and still the customizer doesn’t want to save and publish. I’ve contacted my website host to see if there is something about 4.8 that isn’t compatible with them.

    RESOLVED! My website host updated my PHP settings, and asked me to clear my browser cache. After this was done, the customizer tool is working. After clicking the “Safe and Publish” button, I see the “Saved” button appear for the first time. Double-checked the site, and its showing the updated header image. Sweet.

    Good to hear 🙂

    Thank you for your help!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Customize tool not saving changes’ is closed to new replies.