Support » Fixing WordPress » Customize.php not working

  • Resolved mrblond

    (@mrblond)


    I’ve created and adjusted all main aspects of my new site using my localhost and everything is okay.

    Yesterday, I’ve installed wordpress on my real public host server, activated the theme and all needed pligins but was surprised when I’ve tried to start the customization option. It just opened a black screen. The sidebar where usually are the options for customization of the theme is also blank with the name of the site on the top end.

    Now, I can’t start the site because customization options not working.

    Could you help what is the problem?

Viewing 6 replies - 1 through 6 (of 6 total)
  • The Customizer is written in javascript, and the theme and plugins also have javascript, which may have errors. This can cause the WP core javascript to not run, because the error stops execution.
    I suggest you read this page to see how to determine the script with the error, and you can then ask the plugin or theme author about it on their support forum.

    Using Your Browser to Diagnose JavaScript Errors

    Following the above instructions, I opened the Chrome browser console and found this error record:

    Failed to load resource:
    customize.php?url=https%3A%2F%2Fcatalog.philarooms.com%2F:1
    the server responded with a status of 500 ()

    There are other messages in the console with attention remark:

    JQMIGRATE: ‘ready’ event is deprecated jquery-migrate.js:45
    console.trace
    migrateWarn @ jquery-migrate.js:47

    JQMIGRATE: jQuery.fn.load() is deprecated jquery-migrate.js:45
    console.trace
    migrateWarn @ jquery-migrate.js:47

    • This reply was modified 1 year, 2 months ago by mrblond.
    • This reply was modified 1 year, 2 months ago by mrblond.
    • This reply was modified 1 year, 2 months ago by mrblond.
    • This reply was modified 1 year, 2 months ago by mrblond.
    • This reply was modified 1 year, 2 months ago by mrblond.
    • This reply was modified 1 year, 2 months ago by mrblond.

    The first error message says that your site is getting a 500 error. You will have to figure out why. You can look on the server for an error log. You can also enable Debug mode in WordPress:
    https://codex.wordpress.org/Editing_wp-config.php#Debug

    You can install the Health Check plugin and see if that helps. It has a Troubleshoot mode.

    I found it.

    It is the plugin “HappyForms” that causes the problem.
    I wonder how it works perfect on my localhost and not on the public host?!?!

    Difference in PHP version used, maybe?

    You would have to ask at the plugin’s support forum. It could be the PHP version.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Customize.php not working’ is closed to new replies.