Support » Fixing WordPress » Customize & Live Preview not working

  • Please help me. The customizer & live preview on my blog aren’t working, and I have already tried the recommended solutions from other “resolved” forums:

    ”– deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).
    – switching to the default theme to rule out any theme-specific problems.
    – resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.
    – re-uploading all files & folders – except the wp-content folder and wp-config.php & root .htaccess files – from a fresh download of WordPress.”

    Nothing has worked.

    I am not sure what is wrong and its driving me nuts! I even tried cleaning my database and tried the WP-Sweep plugin to catch any files I may have missed.

    Please, are there any other solutions that I am missing? I do not want to start from the scratch just to get this to work again…

Viewing 2 replies - 1 through 2 (of 2 total)
  • Thread Starter tajanator


    Ok…. I just tried it again from another browser (microsoft edge) and it tried to load, gave a “website not responding” error, then reloaded on its own, and began working! WTF??!!.

    So there must be an error that Chrome can’t fight beyond but Edge can? Now I am even more confused.

    Can this be a browser issue? Is chrome incompatible with wordpress or is there a load error that chrome just can’t fight past??

    This is likely a combination of a caching difference between your Edge browser and your Chrome browser and a temporarily broken piece of script on your server being cached by Chrome (but not by Edge). Try clearing your Chrome cache and then refreshing the live preview. If that does not help, here is a detailed guide for how to try to get live preview working again:

    Internal Server Error HTTP 500 in WordPress Customizer


    Last Updated:
    1 year ago

    Time to Read: 3 minutes

    Problem Description
    When you attempt to customize your site via Appearance → Customize, you get an Internal Server Error (HTTP 500 range) in the Customizer preview or the customizer redirects to this error page in the browser.

    If you are getting the customizer interface and preview with a normal 404 Not Found error see Layers Pages: No Posts Found or 404 Error in Customizer
    If you have a WordPress MultiSite, the following steps can still help, but see this conversation regarding .htaccess configuration and ensuring WordPress is not installed in a subdirectory of another website.

    This is sometimes caused by plugin conflicts but is usually a server configuration issue.

    1. Ensure WordPress, Layers and all plugins are updated. If your  premium plugins do not have an auto-update feature, you will need to check your account on the Layers website or CodeCanyon to download an updated copy to reinstall it.
    2. If you are using a Layers parent theme, and allows you to modify, or add to, the functionality of that parent theme. The child theme article on the WordPress Codex shows how to create a basic child theme and explains what you can do with it.Making a child theme is very simple. Create a directory by using FTP or whatever file management application your host provides. Child themes are the primary way to add front-end functionality and presentation modifications to Layers.Related Reading:Child Theming for Layers” class=”glossaryLink ” target=”_blank”>Child Theme, deactivate it and activate the main Layers theme, then retest the customizer. If this solves it, your child theme may be causing the problem.
    3. Ensure Layers is installed in the correct folder.
    4. Go to Settings → Permalinks are the permanent URLs to your individual weblog posts, as well as categories and other lists of weblog postings. A permalink is what another weblogger will use to link to your article (or section), or how you might send a link to your story in an e-mail message. The URL to each post should be permanent, and never change — hence permalink.Click to view full description and examples” class=”glossaryLink ” target=”_blank”>Permalinks and ensure Post Name is selected, then click Save to regenerate all links, then test again.
    • If the error still occurs, go back to Settings → Permalinks and choose Default, then test again. If this works, skip to Step 6
    • If changing/resaving permalinks does not work, continue:
    • Go to Plugins and deactivate all plugins*. If you have caching plugins, clear the cache first before deactivating.
    • *The following plugins can stay active and have been cleared as the cause of this problem:
    • Layers comes in three license tiers to meet your needs, Single, Multi-Site and Developer, starting at just $49 including lifetime updates and support.Learn More About Layers Pro” class=”glossaryLink ” target=”_blank”>Layers Pro
    • StoreKit
    • WooCommerce
    • Try the customizer again from Appearance → Customize.
    • If this works, click around your menu to visit other Layers pages and ensure they work. You will need to reactivate plugins one at a time and test after each until you find the one causing the problem
    • If the error reoccurs, it is probably not a plugin issue. Continue:

    Verify Server Configuration
    The following require some understanding of FTP or how your web space is setup. If you are not comfortable working with your server config, we recommend you contact your web host to let them know you get an internal server error when trying to use the WordPress customizer and would like help troubleshooting your ,htaccess and PHP configuration.
    Check .htaccess
    This file controls some aspects of security on your site, and how redirects work, including permalinks in WordPress. Some security plugins will modify this incorrectly or in too strict a manner which causes problems in WordPress. Your host may also enforce specific .htaccess rules that cause problems in WordPress.

    1. Single installs: Connect to your server using an FTP client and delete the .htaccess file.
    2. WordPress Multisite: Visit Network Admin → Network Setup and verify your wp-config and .htaccess are configured as outlined on that page.
    3. Test again and see if the problem is resolved. If so, go to Settings Permalinks, ensure Post Name is selected and re-save.
    • If turning on permalinks breaks customizing again, contact your host to troubleshoot. For best results, be sure to host your site on a host that offers WordPress hosting, or uses Linux servers.

    Check PHP & Caching

    1. PHP should be at 5.4 to 5.6. 5.7 is in beta and should not be used on a live site.
    2. Disable eaccelerator for PHP. See this article for help or ask your host.
    3. Turn off other server-side caching –  In most cases, it is better to manage caching from WordPress with a plugin designed for WordPress. unless you are on Managed WP hosting. Your host can assist you with disabling server caching such as Varnish, Pagespeed, X-Cache or Cloudflare etc – usually there is a setting in your domain page on your cPanel to turn these off.

    See Also

    Grids look broken in Safari

    How to Redirect Post Category Links to Layers Pages

    • This reply was modified 5 years, 11 months ago by mavaddat. Reason: Removed broken HTML
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Customize & Live Preview not working’ is closed to new replies.