Support » Plugin: Min and Max Quantity for WooCommerce » Customize Error Message

  • Resolved wpdv

    (@wpdv)


    Thank you for this great plugin! I am trying to change the error message that’s currently shown on the cart page when too many items have been added. I found the text in your .pot file, and I’ve replaced it with mine, cleared caches, but I’m unable to display the updated text. Do I need to make a change in another file? Appreciate your thoughts. current cart error message and the .pot file

Viewing 4 replies - 1 through 4 (of 4 total)
  • Thread Starter wpdv

    (@wpdv)

    I also used Poedit to generate a new .po and .mo files in English. Still no luck. Thanks for any pointers you can provide.

    Plugin Author RazyRx

    (@razyrx)

    Hello,

    If you use Limitations, then you can change text for in on Limitation edit page -> Text tab.
    Option “Use local text” must be enabled.

    Regards,
    Oleg

    Thread Starter wpdv

    (@wpdv)

    Thank you for your suggestion. I tried using Limitations, added all of the products that I wanted to limit to a max qty of 12. However, it would only allow (1) item with a qty of 12 in the cart. I was unable to add any other item without getting an error message. Additionally, this broke our shipping rules as it may be a higher priority rule. Not sure. We have complicated shipping rules based upon zip codes. All of these shipments are made by dump trucks. What does seem to work best is setting the maximum quantity of 12 at the product level for each product that I wish to limit to 12. It allows for multiple products to be added to the cart, which allows for separate shipments (as the shipping rules are calculated correctly) from the same order, and the shipping rules are not broken — as seen here. I’d like to change the default error message in both of this instances to my custom text, but for whatever reason I cannot get it to display. I have added my text as shown in the screenshot and uploaded the updated .po and mo files into the min/max plugin folder under license. I removed the 2 RU files (seen here). Here is what the translated .po file looks like. Is there something I’m doing wrong?

    Thread Starter wpdv

    (@wpdv)

    Again I would like to thank you for your plugin. I was able to customize the text using the Say What? plugin. Have a wonderful day!!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Customize Error Message’ is closed to new replies.