Support » Plugin: TK Google Fonts » Customiser>TK Google Fonts’ use overrides custom CSS class font-family

  • In Customiser > TK Google Fonts, I had chosen for one class (.site-title) a font that was installed in TK Google Fonts > Settings from fonts.google.com.

    I then wished to stop using that font (or any Google font) for the class, so I returned to Customiser and selected the blank at the top of the list of installed Google fonts.

    The result was that the class was then styled by TK Google Fonts with “font-family: none !important”. This is overriding any font that I then try to set in Customiser > Addditional CSS, even when I use !important.

    Given that the Customiser fonts list is blank and does not say “None”, I think that the expected result is that TK Google Font stop applying (i.e. remove) its font-family rule for that class. It should not apply a rule of “font-family: none !important”, for which a use-case is not obvious to me.

    As a test, I disabled TK Google Fonts. The “font-family: none !important” rule disappeared and I was able to apply any uploaded or default font of my choice to the class via custom CSS as expected.

    WordPress: 4.9.8
    PHP: 5.6.30
    Theme: _tk

Viewing 1 replies (of 1 total)
  • Plugin Contributor konradS

    (@konrads)

    hey there, issue is noted and will be fixed with net release, wonder how that happened, obviously there should not be any styling upon de-selecting,

    thanks for the feedback, next version coming soon!

    BTW did it help to de-activate and then re-activate? or does same issue persist?

    Cheers Konrad

Viewing 1 replies (of 1 total)
  • The topic ‘Customiser>TK Google Fonts’ use overrides custom CSS class font-family’ is closed to new replies.