Support » Plugin: Decorator - WooCommerce Email Customizer » Customiser blank

  • Resolved inkandfoil

    (@inkandfoil)


    Hi

    I’m trying to style my emails for email centre using decorator, but for some reason the customiser is blank when it opens.

    Any ideas?

Viewing 13 replies - 1 through 13 (of 13 total)
  • this is just a guess.
    try email-styles.php file in the woocommerce emails template folder.
    this “like-file” may also be in your theme folder, and be reading that.

    Mine is blank also… I couldn’t understand what the email-styles.php could help…
    I’ve tried to copy the file to my theme’s folder… and nothing happened.

    I’m using storefront.

    Plugin Author RightPress

    (@rightpress)

    Hi there,

    Could you please let me know your WordPress and WooCommerce versions as well as what other plugins you have on system?

    Also, it would be great if you could check both PHP error log and browser’s console for JS errors (if you know how to do that).

    Paul

    Hi Paul,

    I’m using WP 4.7.2 and WC 2.6.14. I’ve plenty of other plugins active and I’m using multisite. If you really want to, I can send you my list of plugin (about 40) đŸ˜›

    PHP There’s no other error regarding your plugin, just:
    [10-Feb-2017 17:20:42 UTC] PHP Warning: Creating default object from empty value in /var/www/vhosts/iacess.pt/httpdocs/wp-content/plugins/wp-all-export-pro/classes/updater.php on line 236

    JS
    JQMIGRATE: Migrate is installed, version 1.4.1
    gridstack.js:35 gridstack.js: Option item_class is deprecated as of v0.2.5 and has been replaced with itemClass. It will be **completely** removed in v1.0.
    e @ gridstack.js:35
    gridstack.js:35 gridstack.js: Option cell_height is deprecated as of v0.2.5 and has been replaced with cellHeight. It will be **completely** removed in v1.0.
    e @ gridstack.js:35
    add-widgets.js:39 Uncaught TypeError: Cannot read property ‘availableWidgets’ of undefined
    at n.initialize (add-widgets.js:39)
    at n.e.View (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,underscore,customize-base,wp-a11y,wp-util,cu…:76)
    at n.constructor (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,underscore,customize-base,wp-a11y,wp-util,cu…:78)
    at new n (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,underscore,customize-base,wp-a11y,wp-util,cu…:76)
    at n.initialize (configurator.js:48)
    at n.e.View (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,underscore,customize-base,wp-a11y,wp-util,cu…:76)
    at n.constructor (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,underscore,customize-base,wp-a11y,wp-util,cu…:78)
    at new n (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,underscore,customize-base,wp-a11y,wp-util,cu…:76)
    at n.initConfigurator (customizer.js:125)
    at n.initialize (customizer.js:45)
    jquery-migrate.min.js?ver=1.4.1:2 JQMIGRATE: Migrate is installed, version 1.4.1

    Same Problem here …

    WordPress: 4.7.2

    Woocommerce: 2.6.14

    Screenshot: http://imgur.com/a/CEkn6

    Any ideas?

    regards from germany ..

    Any ideas @rightpress ?

    Plugin Author RightPress

    (@rightpress)

    Hey guys,

    Sorry for the delay in getting back to you.

    Could someone please drop an email to info@rightpress.net and help me find the problem? I am unable to replicate this locally.

    Thanks,
    Paul

    Is this your route of navigation?

    Woocommerce> Settings> Email(tab)> Open Decorator(button)

    This should be the way to access it.
    I can see my customizer settings.
    using wordpress 4.7.3
    using woocommerce 2.6.14
    using decorator 1.0.1

    Plugin Author RightPress

    (@rightpress)

    Thanks to one of you we now know what the problem is.

    It is related to Storefront Mega Menus extension. I logged a bug report for this:
    https://github.com/woocommerce/storefront/issues/558

    If you do not use Storefront Mega Menus, it may be some other theme/extension that has similar bug.

    A quick temporary fix is to open includes/classes/rp-decorator-customizer.class.php and comment out the line that goes just below comment “Remove unrelated components” and starts with add_filter (line 71 in version 1.0.1). Just keep in mind that some unrelated content/settings may be displayed if you choose to do so.

    I hope this helps!

    Paul

    Same error for me. The screen loads, but without anything on the main screen, just the aside bar. Tks.

    Same problem here. However, I am unclear about what I am supposed to do about the /woocommerce/templates/emails folder/files.

    I’ve commented out line 71 in includes/classes/rp-decorator-customizer.class.php but that did nothing.

    This was working fine with the same theme and an older version of woocommerce, so likely they broke the customizer, but I do not know what steps to take next.

    Please advise.

    Have this fixed yet? I’m having the same issue.

    Plugin Author RightPress

    (@rightpress)

    Hello everyone,

    Even though we found what the cause for this was in the past for some users, it may or may not be the same issue with every new case.

    Basically, a blank page indicates there is some fatal PHP error or some fatal Javascript error. Please check your PHP error log (after enabling WP debug mode and/or error logging) as well as your browser’s Console for any errors.

    I would be happy to look into each case individually but need more information from your side guys.

    Paul

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Customiser blank’ is closed to new replies.