Support » Plugin: WooCommerce » Customer order data does not get saved and total price is zero

  • Resolved mike8040

    (@mike8040)


    Hello,

    I have migrated from my old hoster to Siteground. Everything worked out great besides orders being corrupt now. When I do a test order. No customer data from the fields get saved. Just blank and thank you page shows N.A. Also the total price is 0 even though on the checkout page the total price was correctly calculated. Can anyone point me in a direction?

    – updated the database
    – updated to the latest woo
    – updated germanized plugin

    • This topic was modified 3 months ago by mike8040.
Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Support Mirko P.

    (@rainfallnixfig)

    Hi @mike8040,

    Can you please tell us how did you migrate orders to the new site? Old orders were imported and are being displayed correctly? Let’s see if there are errors on the WooCommerce Logs. Kindly provide us the following:

    • System Status: You can find it via WooCommerce > Status. Select “Get system report” and then “Copy for support”. Once you’ve done that, paste it here in your response.
    • Error Log: Share a copy of any fatal error log found under WooCommerce > System Status > Logs (if available).
    • Console tab: Right-click on the Order page where customer data is not saved or press F12 on the keyboard and select “Inspect” (this option will show up on most browsers). In the developer tools that will pop up you should see a “Console” tab. From there, please send us a screenshot of what’s being displayed using a tool like snipboard.io.

    Thanks!

    Shane Gowland

    (@thewebatom)

    Would also love to see the system status for this issue.

    Encountering something similar and suspect a plugin conflict, but haven’t been able to narrow it down.

    Thread Starter mike8040

    (@mike8040)

    Well I was fighting with the Siteground support the last several days. I’m pretty sure I found the reason for the missing customers data after checkout. Its their Memcached feature. Without their Memcached the order data gets saved. I disabled anything but Polylang, Woocommerce and Elementor to get any plugins out that are not barebone essential. It is their Memcached..

    Siteground is pretty popular and is mentioned a lot for their speed and service bla bla bla. After having all sort of bugs (Migration plugin and their backup feature) and most important contact with their careless and disinterested support I have a totally different opinion. They are still friendly but its useless when they aren’t a bit interested to help. Its stunning. I’m really thinking of bloggin their responses as makes me speechless.

    They point the finger now to the WooCommerce developers after acknowledging that the issue is their Memcached after riding the plugin conflict route day to day.

    Funny as I ordered their “WooCommerce Hosting” package and the most important function of an E-Commerce system doesn’t work there … I’m still in the 30 days money back thing and since without Memchached the site behave like my actual hoster I see no point staying there. Especially after experiencing their support.

    So if a Woocommerce Dev could write 1 or 2 sentences about Memcached compatibility and if its beneficial to chase the error hole, I would be grateful. With Memcache I really like the performance. Especially in the back end.

    • This reply was modified 2 months, 3 weeks ago by mike8040.
    Hristo Pandjarov

    (@hristo-sg)

    SiteGround Representative

    Hristo from SG here. The issue is not with WooCommerce but with WooCommerce plugins / custom theme functionality you have. One of them is simply not written to work well with persistent object caching like Memcached. Without 3rd party plugins causing issues, WooCommerce works great with Memcached, it has been tested thoroughly and it is being used by thousands of sites without problems.

    It is not our Memcached, it is Memcached. Plugins either use it or not, it is not in our control how they store and fetch objects from Memcached.

    Thread Starter mike8040

    (@mike8040)

    @hristo-sg
    Again. Read exactly what I said! I went all trough it. I had just Elementor, WooC and Polylang with the twentytwenty theme active and still had this massive bug. It like saying your car is not driving correct because you have special shoes on and they don’t work with the accelerator…
    That response is exactly what I meant earlier.

    Plugin Support Martyn J. a11n

    (@martynmjones)

    Hey @mike8040,

    I had just Elementor, WooC and Polylang with the twentytwenty theme active and still had this massive bug.

    Looking online I’ve found other instances of people having various issues when using Polylang and Memcached, some topics specifically referring to configuration on SiteGround.

    To test if that is where the issue is coming from I’d recommend you temporarily disable Polylang and place a test order to see if customer and price data is correctly saved.

    If the issue goes away for that test then we’ll know for sure where the problem is coming from. At that point, I would recommend you reach out to the developers of Polylang directly to see if they have any advice on working with Memcached and/or SiteGround.

    Kind regards,

    Thread Starter mike8040

    (@mike8040)

    THIS: https://wordpress.org/support/topic/sg-optimizer-5-0-7-problem-with-woocommerce/

    Exactly the same issue I’m facing with 0$ total amount with SG Memcached plugin. No mentioning of Polylang there. He fixed it by using SG optimizer 4.0.7. No real communicated outcome there unfortunately.

    Plugin Support Stuart Duff – a11n

    (@stuartduff)

    Automattic Happiness Engineer

    Hey @mike8040,

    As this behaviour is not directly related to the WooCommerce plugin itself we’ll set this topic to be resolved for the time being. If you have any further questions relating to this behaviour, you can reopen it again if you need be.

    Thread Starter mike8040

    (@mike8040)

    @hristo-sg

    It is not our Memcached, it is Memcached

    “…Memcached service, which is part of SuperCacher, uses our own implementation of the popular Memcached system.”
    Source: https://www.siteground.com/tutorials/wordpress/optimize-performance/

    @stuartduff

    As this behaviour is not directly related to the WooCommerce plugin itself

    Siteground claims it’s a bug by Woocommerce and send me here. So now you are saying it’s a bug by Siteground?
    So in your own words. It is not resolved. Just seems nobody seems to care and points the finger to the neighbor garden.
    I can understand you want to clean up the unresolved list but it’s unfair to claim it as resolved when it not true.

    Plugin Support Mirko P.

    (@rainfallnixfig)

    Hey @mike8040,

    Thanks for getting back to the WooCommerce forum.

    Siteground claims it’s a bug by Woocommerce and send me here. So now you are saying it’s a bug by Siteground?

    As far as I can see, @hristo-sg from SiteGround specifically said that the issue is not with WooCommerce core but with third-party plugins enabled on your site along with WooCommerce. You didn’t actually perform a conflict test the way it should be, as that would involve deactivating all plugins except WooCommerce core. You can find a more detailed explanation on how to do a conflict test here: https://docs.woocommerce.com/document/how-to-test-for-conflicts/.

    This thread will stay resolved for the time being but if you have any more questions please feel free to open a new topic on this forum.

    Cheers.

    Thread Starter mike8040

    (@mike8040)

    I did. I may not describe it here in detail. Went all the steps and wasted time. Believe me it is not a user error. This function is deactivated since then.
    Funny that @hristo-sg did not respond to his claim which is obviously not right as I showed the proof.

    Plugin Support Phillip C. a11n

    (@phillipwoo)

    Hello @mike8040

    Thanks for contacting us to let us know the conflict test was conducted as we’ve recommended with all plugins except WooCommerce disabled. At this point it sounds like the issue is external to our support. If there are still issues with SiteGround’s service I recommend contacting their support team again. They should be able to walk you through how to mitigate this issue with Memcached and how it is implemented here.

    All the best 🙂

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.