Support » Plugin: WooCommerce » Customer can’t log out

Viewing 13 replies - 1 through 13 (of 13 total)
  • My WC Status:

    
    ### WordPress Environment ###
    
    Home URL: https://www.staging1.cookandconnect.com
    Site URL: https://www.staging1.cookandconnect.com
    WC Version: 3.4.3
    Log Directory Writable: ✔
    WP Version: 4.9.7
    WP Multisite: –
    WP Memory Limit: 768 MB
    WP Debug Mode: –
    WP Cron: ✔
    Language: en_US
    External object cache: –
    
    ### Server Environment ###
    
    Server Info: Apache
    PHP Version: 7.0.30 - We recommend using PHP version 7.2 or above for greater performance and security. How to update your PHP version
    PHP Post Max Size: 128 MB
    PHP Time Limit: 120
    PHP Max Input Vars: 3000
    cURL Version: 7.59.0
    OpenSSL/1.0.2k
    
    SUHOSIN Installed: –
    MySQL Version: 5.6.36-82.1-log
    Max Upload Size: 128 MB
    Default Timezone is UTC: ✔
    fsockopen/cURL: ✔
    SoapClient: ✔
    DOMDocument: ✔
    GZip: ✔
    Multibyte String: ✔
    Remote Post: ✔
    Remote Get: ✔
    
    ### Database ###
    
    WC Database Version: 3.4.3
    WC Database Prefix: wp_
    MaxMind GeoIP Database: ✔
    Total Database Size: 23.80MB
    Database Data Size: 15.98MB
    Database Index Size: 7.82MB
    wp_woocommerce_sessions: Data: 0.02MB + Index: 0.02MB
    wp_woocommerce_api_keys: Data: 0.02MB + Index: 0.03MB
    wp_woocommerce_attribute_taxonomies: Data: 0.02MB + Index: 0.02MB
    wp_woocommerce_downloadable_product_permissions: Data: 0.02MB + Index: 0.05MB
    wp_woocommerce_order_items: Data: 0.02MB + Index: 0.02MB
    wp_woocommerce_order_itemmeta: Data: 0.06MB + Index: 0.03MB
    wp_woocommerce_tax_rates: Data: 0.02MB + Index: 0.06MB
    wp_woocommerce_tax_rate_locations: Data: 0.02MB + Index: 0.03MB
    wp_woocommerce_shipping_zones: Data: 0.02MB + Index: 0.00MB
    wp_woocommerce_shipping_zone_locations: Data: 0.02MB + Index: 0.03MB
    wp_woocommerce_shipping_zone_methods: Data: 0.02MB + Index: 0.00MB
    wp_woocommerce_payment_tokens: Data: 0.02MB + Index: 0.02MB
    wp_woocommerce_payment_tokenmeta: Data: 0.02MB + Index: 0.03MB
    wp_woocommerce_log: Data: 0.02MB + Index: 0.02MB
    wp_aws_cache: Data: 0.08MB + Index: 0.00MB
    wp_aws_index: Data: 0.06MB + Index: 0.00MB
    wp_bm_user_location: Data: 0.02MB + Index: 0.02MB
    wp_bp_activity: Data: 0.02MB + Index: 0.16MB
    wp_bp_activity_meta: Data: 0.02MB + Index: 0.03MB
    wp_bp_groups: Data: 0.02MB + Index: 0.05MB
    wp_bp_groups_groupmeta: Data: 0.02MB + Index: 0.03MB
    wp_bp_groups_members: Data: 0.02MB + Index: 0.09MB
    wp_bp_messages_messages: Data: 0.02MB + Index: 0.03MB
    wp_bp_messages_meta: Data: 0.02MB + Index: 0.03MB
    wp_bp_messages_notices: Data: 0.02MB + Index: 0.02MB
    wp_bp_messages_recipients: Data: 0.02MB + Index: 0.08MB
    wp_bp_notifications: Data: 0.02MB + Index: 0.11MB
    wp_bp_notifications_meta: Data: 0.02MB + Index: 0.03MB
    wp_bp_xprofile_data: Data: 0.02MB + Index: 0.03MB
    wp_bp_xprofile_fields: Data: 0.02MB + Index: 0.08MB
    wp_bp_xprofile_groups: Data: 0.02MB + Index: 0.02MB
    wp_bp_xprofile_meta: Data: 0.02MB + Index: 0.03MB
    wp_commentmeta: Data: 0.02MB + Index: 0.03MB
    wp_comments: Data: 0.05MB + Index: 0.09MB
    wp_defender_lockout: Data: 0.02MB + Index: 0.00MB
    wp_defender_lockout_log: Data: 0.02MB + Index: 0.00MB
    wp_hook_list: Data: 0.02MB + Index: 0.00MB
    wp_links: Data: 0.02MB + Index: 0.02MB
    wp_options: Data: 2.28MB + Index: 0.09MB
    wp_pmxe_exports: Data: 0.22MB + Index: 0.00MB
    wp_pmxe_google_cats: Data: 0.39MB + Index: 0.00MB
    wp_pmxe_posts: Data: 0.02MB + Index: 0.00MB
    wp_pmxe_templates: Data: 0.02MB + Index: 0.00MB
    wp_postmeta: Data: 4.52MB + Index: 0.75MB
    wp_posts: Data: 3.52MB + Index: 0.22MB
    wp_pv_commission: Data: 0.02MB + Index: 0.00MB
    wp_revslider_css: Data: 0.13MB + Index: 0.00MB
    wp_revslider_layer_animations: Data: 0.02MB + Index: 0.00MB
    wp_revslider_navigations: Data: 0.02MB + Index: 0.00MB
    wp_revslider_sliders: Data: 0.02MB + Index: 0.00MB
    wp_revslider_slides: Data: 0.02MB + Index: 0.00MB
    wp_revslider_static_slides: Data: 0.02MB + Index: 0.00MB
    wp_rg_form: Data: 0.02MB + Index: 0.00MB
    wp_rg_form_meta: Data: 0.02MB + Index: 0.00MB
    wp_rg_form_view: Data: 0.02MB + Index: 0.03MB
    wp_rg_incomplete_submissions: Data: 0.02MB + Index: 0.02MB
    wp_rg_lead: Data: 0.02MB + Index: 0.03MB
    wp_rg_lead_detail: Data: 0.02MB + Index: 0.06MB
    wp_rg_lead_detail_long: Data: 0.02MB + Index: 0.00MB
    wp_rg_lead_meta: Data: 0.02MB + Index: 0.05MB
    wp_rg_lead_notes: Data: 0.02MB + Index: 0.03MB
    wp_signups: Data: 0.08MB + Index: 0.06MB
    wp_stream: Data: 1.17MB + Index: 0.39MB
    wp_stream_meta: Data: 2.02MB + Index: 4.27MB
    wp_termmeta: Data: 0.02MB + Index: 0.03MB
    wp_terms: Data: 0.02MB + Index: 0.03MB
    wp_term_relationships: Data: 0.02MB + Index: 0.02MB
    wp_term_taxonomy: Data: 0.02MB + Index: 0.03MB
    wp_usermeta: Data: 0.08MB + Index: 0.06MB
    wp_users: Data: 0.02MB + Index: 0.05MB
    wp_wcv_feedback: Data: 0.02MB + Index: 0.00MB
    wp_wc_booking_relationships: Data: 0.02MB + Index: 0.03MB
    wp_wc_download_log: Data: 0.02MB + Index: 0.03MB
    wp_wc_webhooks: Data: 0.02MB + Index: 0.02MB
    wp_weforms_entries: Data: 0.02MB + Index: 0.02MB
    wp_weforms_entrymeta: Data: 0.02MB + Index: 0.03MB
    wp_wpuf_subscribers: Data: 0.02MB + Index: 0.02MB
    wp_wpuf_transaction: Data: 0.02MB + Index: 0.06MB
    wp_wsluserscontacts: Data: 0.02MB + Index: 0.02MB
    wp_wslusersprofiles: Data: 0.02MB + Index: 0.03MB
    
    ### Post Type Counts ###
    
    acf-field: 2
    acf-field-group: 1
    attachment: 63
    bookable_person: 6
    bp-email: 16
    customize_changeset: 17
    nav_menu_item: 18
    page: 35
    post: 6
    postman_sent_mail: 250
    product: 44
    revision: 296
    shop_coupon: 1
    shop_order: 21
    shop_order_refund: 1
    shop_order_vendor: 50
    wc_booking: 62
    wpuf_contact_form: 1
    wpuf_forms: 1
    wpuf_input: 24
    
    ### Security ###
    
    Secure connection (HTTPS): ✔
    Hide errors from visitors: ✔
    
    ### Active Plugins (1) ###
    
    WooCommerce: by Automattic – 3.4.3
    
    ### Settings ###
    
    API Enabled: ✔
    Force SSL: ✔
    Currency: USD ($)
    Currency Position: left
    Thousand Separator: ,
    Decimal Separator: .
    Number of Decimals: 2
    Taxonomies: Product Types: booking (booking)
    external (external)
    grouped (grouped)
    simple (simple)
    variable (variable)
    
    Taxonomies: Product Visibility: exclude-from-catalog (exclude-from-catalog)
    exclude-from-search (exclude-from-search)
    featured (featured)
    outofstock (outofstock)
    rated-1 (rated-1)
    rated-2 (rated-2)
    rated-3 (rated-3)
    rated-4 (rated-4)
    rated-5 (rated-5)
    
    ### WC Pages ###
    
    Shop base: #4 - /kitchens/
    Pending Bookings: #5 - /cart/
    Checkout: #6 - /checkout/
    My account: #7 - /my-account/
    Terms and conditions: #145 - /terms-of-service/
    
    ### Theme ###
    
    Name: Twenty Seventeen
    Version: 1.6
    Author URL: https://wordpress.org/
    Child Theme: ❌ – If you are modifying WooCommerce on a parent theme that you did not build personally we recommend using a child theme. See: How to create a child theme
    WooCommerce Support: ✔
    
    ### Templates ###
    
    Overrides: –
    
    Plugin Support Zach W

    (@dynamiczach)

    Automattic Happiness Engineer

    Howdy!

    If you’ve already deactivated all plugins but WooCommerce and switched to the Twenty Seventeen theme, my guess here would be that this is an issue with caching.

    Looks like the staging site is hosted by Siteground, so I’d suggest contacting them and having them check for any caching issues.

    Also, make sure the My Account page/section (as well as the cart and checkout pages) is being excluded from any cache settings.

    One more thing, WooCommerce is not compatible with Cloudflare Flexible SSL, as mentioned at the bottom of their SSL FAQ page here: https://docs.woocommerce.com/document/ssl-faq/#section-10 – are you using that option by chance?

    I’d start there, and let us know how that goes!

    Thanks. The only caching set up is a static cache (although I don’t know if staging is cached in any case). I disabled that in cpanel, cleared cookies+cache on the browser again, even opened a new browser tab, but no luck. 🙁 Puzzling.

    • This reply was modified 1 year, 3 months ago by  Jim.

    I investigated the Cloudflare settings. Flexible SSL was on, so I turned it off. Also purged the Cloudflare cache, set it to development mode, and played with Cloudflare caching level (basic, simple, aggressive). Nothing I did changed the behavior.

    Plugin Support Con Schneider

    (@conschneider)

    Automattic Happiness Engineer

    Hi Jim,

    Since this is a case that involves credentials to check I am afraid there is not much we can do via this public forum.

    But we can always check the error logs.
    Can you request the PHP error log and attach them here to your next reply. A maximum of the last 10 entries will do.
    WooCommerce also attempts to log any fatal errors. You can find these under WooCommerce > Status >> Logs (click on the tab).

    It now appears this was some kind of staging/database issue. When we pushed staging to live, the site was redirecting back to staging. The host support cleaned out the staging URLs wherever they were stored, and now I can log out normally.

    Sorry for the hassle.

    I have a similar issue. When a customer logs into the site via the credential fields on the “My Account” page, they can log in, but they cannot log out. They get to an “Are you sure you want to logout” page. After clicking the link on that page, they are redirected to the homepage, but if they click the “My Account” link, it takes them to their account as if they are still logged in (never seeing the login credential fields a second time after logging out). My support team at my host, WP Engine, wrote the below message. Hoping a Woocommerce expert can direct me and my WP Engine support team on what to do next:

    ***

    After further review, we were able to identify the cause of the issue. Something within WooCommerce appears to be generating a nonce that does not match the nonce generated by WordPress. Once the logout redirect takes place, the request 403s, and the rest of the logout function is unable to process.

    At this point, it may be worth reaching out to WooCommerce to see what can be done to ensure the nonce being generated can verify. We do have the _wpnonce argument excluded from caching. We have also verified that WordPress core has no edits and verifies against the checksums. It may be a configuration issue within Woo itself or a companion plugin.

    ***

    I should add, the site in question is: http://n1critical.com/my-account

    @mheinen1critical it looks like you fixed the issue. Can you let us know what the solution was in the end?

    THanks!

    lapapo

    (@lapapo)

    Hello,
    I am having the same issue with the logout link not going to a logout page. Just redirects to the My Account page. Any idea on how to fix this would be appreciated.

    I’m also having this same issue. I’m on WP Engine and a Multisite.

    The same problem with all plugins besides WooCommerce deactivated and with a default 2017 theme active.

    fransing

    (@fransing)

    same here,
    on multisite and having completely the same problem. customer just can’t logout from my-account

    anyone has a solution for this?

    Plugin Support Zach W

    (@dynamiczach)

    Automattic Happiness Engineer

    Howdy @jamestryon & @fransing!

    Since this is already a Resolved thread and the original poster did not have a multisite, can you please create a new support thread? Once you do that, we’ll work with you there. Thanks!

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.