WordPress.org

Forums

Types
[resolved] Custom type not showing in admin menu (4 posts)

  1. Jason Judge
    Member
    Posted 1 year ago #

    I set up a custom type "products" and a custom taxonomy for it. I had some problem creating fields (they would not consistently be created) so I installed "Advanced Custom Fields" to handle the custom fields on the products. That worked nicely.

    I imported 300+ products using the "CSV Importer" plugin. That also worked fine.

    I installed "oik base plugin" and "oilk fields" so can view the products in tabulated form within a page. That all worked find and great too.

    I'm telling you all this in case there are some interactions that you know about.

    I came back to this the next day, and found the Products post type no longer appears in the admin menu. It did the day before, so I have no idea what happened. The post type is still there, as is the imported data, but I just cannot see it in the admin menu.

    I have the post type set to "public", so it should be there, and it was the day before. I really cannot think what could have changed to make it disappear.

    I've turned on all debugging options in WP and cannot see the slightest sign of a notice or warning when the pages load. What could have happened?

    http://wordpress.org/extend/plugins/types/

  2. Jason Judge
    Member
    Posted 1 year ago #

    Okay, I just found the show_in_menu option, and that was unticked. Ticking that fixed the problem.

    I don't know who unticked that. It wasn't me, honest. No, really. I didn't. Dhoh.

  3. lelebart
    Member
    Posted 1 year ago #

    same problem in localhost, but the option is thicked

  4. lelebart
    Member
    Posted 1 year ago #

    ** edit ** removing and recreating the type did the trick.

    [solved]

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Types
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.