Support » Fixing WordPress » Custom thumbnail crop not working

  • The automatic thumbnail crop crops from the center which doesn’t work for all of my thumbnails, so I did a custom crop on my thumbnails. The problem is that the images look correctly cropped in my dashboard, but when I view my site, my custom cropping is gone (it reverts back to default crop). These are the steps I followed to re-crop the thumbnails:

    -Opened up the Media Panel
    -Clicked on Library
    -Found the image I needed to adjust the thumbnail for
    -Clicked on “Edit”
    -Below the image hit the “edit Image” button
    -Under “Thumbnail Settings” I checked off the “Thumbnail” button.
    -Clicked on the image and drug my mouse to crop a cropping square.
    -Clicked the crop tool
    -Clicked Save
    -Clicked “Update Media”

    Like I said, it looks right in the gallery, but on my site, the custom crop is gone. I’ve tried deactivating and reactivating all of my plugins, and emptying my cache.

    Does anyone have any ideas?? I’ve been driving myself crazy trying to troubleshoot. Thanks so much in advance!

Viewing 2 replies - 1 through 2 (of 2 total)
  • Hello,
    I am having the same issue since I’ve updated to WP 3.5 – 3.5.1.

    My issue is:
    Custom FEATURED IMAGE crop is not working for me as well as the custom thumbnail crop.

    I follow the same exact steps as Emily (above), the difference being:

    -Under “Thumbnail Settings” I checked off the “All sizes except thumbnail” button. (If the thumbnail preview looks okay.)

    Same thing again as Emily, I click “save” and “update” and I see my newly cropped image in my dashboard under featured image, but when I view my main front page with the featured image, the crop reverts back to the default crop size which I think is set in the theme. The custom cropping on featured image selection worked perfectly previous to WP 3.5

    I need to create a custom crop/height for each featured image on my home/front page, height depending on each image. This worked perfectly fine before WP 3.5.

    I’ve spent hours today troubleshooting, researching/looking through forum posts on the issues etc. but wasn’t able to find a solution. It looks like there are bugs in the new version of WP 3.5 – 3.5.1 and the new “Media” interface. I hope this issue gets resolved soon!

    Would so appreciate any help! This has been frustrating. Thank you!

    I am having the same issue. I posted something similar in response to another person having this issue, but I noticed that while I pressed the save button, the button was actually greyed out, so cropping seems ineffectual.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Custom thumbnail crop not working’ is closed to new replies.