WordPress.org

Forums

Multiple Themes
[resolved] Custom theme not working (3 posts)

  1. duccio
    Member
    Posted 2 years ago #

    Hi, I like a lot the idea of your plugin and wanted to enable it on my site, but I got an error :-( I created a child custom theme from Twenty Ten and made it the default theme for my website (directory themes/twentytencust), but your plugin reports:

    Please report this problem to the Plugin Author:
    Stylesheet and Template names do not match for Theme Custom From Twenty Ten: twentytencust v.s. twentyten

    Any idea? :-)

    Thanks a lot
    Duccio

    http://wordpress.org/extend/plugins/jonradio-multiple-themes/

  2. jonradio
    Member
    Posted 2 years ago #

    Thank you very much for your report! I just became aware of this problem in the last couple of days, and am actively working towards a solution that should be available in the next 24-36 hours.

    The original plugin design was based on my unawareness of any "real world situation" where Plugin Subdirectory Name, Stylesheet Name and Template Name values, as returned by WordPress, did not match. Obviously, I wasn't aware of how Child Themes worked.

    I am now going through all of the code and looking at all my uses of "theme name", to determine, one by one, whether I should use Subdirectory or Stylesheet or Template Name.

    When ready (within 24-36 hours), I will release a new version of the plugin and post into this thread. To be sure you are notified right away you can either subscribe to this thread or e-mail me directly at http://jonradio.com/contact-us/

  3. jonradio
    Member
    Posted 2 years ago #

    This issue has been resolved in Version 3.3, which was just released a few minutes ago.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Multiple Themes
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic