Connections Business Directory
[resolved] Custom templates (6 posts)

  1. mbdelong
    Posted 2 years ago #

    I'm having trouble with my custom templates that I use to list my business directory.

    In the past, my custom templates were stored in the connections\templates folder. Since I upgraded, that isn't working. I see that templates are supposed to be in the connections_templates folder, each under a different directory. I've tried that, but still I get the "template not found" message.

    What am I doing wrong?



  2. shazahm1
    Plugin Author

    Posted 2 years ago #


    The proper folder structure for a custom template would be:

      -> connections_templates
         -> template-folder-name
            -> template.php
            -> meta.php

    Is this what you have?

  3. mbdelong
    Posted 2 years ago #

    Yes, that is exactly what I have. In meta.php I have:
    $template->name = 'card_name_first_picture_change';
    $template->version = '1.0';
    $template->author = 'MBD';
    $template->description = 'Listing by name';?>

    And in template.php I have the same code that used to be in 'card_name_first_picture_change.php'.

    The strange thing is, I tried installing a template, but it looks like those are entry templates or something. But anyway, after I did that, one of the custom templates started working (card_mod2) even though there is no folder in connections_templates for it. (Here's that one: http://ppbaonline.com/directory-2/)

    If you click on "Click here for members sorted by last name", it brings up the page that doesn't work.

    I also tried putting them in the connections\templates folder - I think maybe that's why card_mod2 is working. However, I put the other one there too, and it's not working.

    Thanks for any help you can give me.


  4. shazahm1
    Plugin Author

    Posted 2 years ago #

    When I go to that link, it does seem the card_name_first_picture_change template is working.

  5. mbdelong
    Posted 2 years ago #

    You're right - now it is working.

    What I don't understand is how the other template is working (card_mod2) here: http://ppbaonline.com/directory-2/ when the only folder in the connections\templates folder is card_name_first_picture_change, not card_mod2!

  6. shazahm1
    Plugin Author

    Posted 2 years ago #


    It really doesn't matter what the folder name so as long as it matches what is being used in the shortcode with the template option. Or perhaps, you have the card_mod2 in the /connections_templates/ folder.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Connections Business Directory
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic