WordPress.org

Forums

Display Widgets
Custom Template - Show on Checked - Not Woring (3 posts)

  1. tommyzone
    Member
    Posted 2 years ago #

    I have a custom template for a page. When I choose Show on Checked and choose the page that is using a custom template the widget is not showing on the page. It only shows on the page when I have Hide on Checked selected and nothing checked.

    Please help

    Regards,

    Thomas

    http://wordpress.org/extend/plugins/display-widgets/

  2. steffanieP22
    Member
    Posted 2 years ago #

    I am having a similar issue. I think it's related to the fact that I'm using the Starkers theme and don't have the correct call on the template page to have the widgets displayed in the first place.

    What should I put in the template (such as the page.php template page) to have the widgets selected in the Widget section to display when the page loads?

    Thanks in advance.

  3. steffanieP22
    Member
    Posted 2 years ago #

    Update:
    After adding
    <?php get_sidebar(); ?>
    to my page.php file I have similar results as tommyzone. However the only page that misbehaves is the home page. Which is the page I've set as a static front page for the site. Below are my results for the home page when the specified settings are selected.

    Results
    'Show on checked' with unchecked home page = no widget
    'Show on checked' with checked home page = no widget
    'Hide on checked' with unchecked home page = shows the widget
    'Hide on checked' with checked home page = shows the widget

    All other pages have the widget displayed or hidden according to how they are selected... It's something about the home page itself...

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Display Widgets
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.