WordPress.org

Support

Support » Multisite » Custom Taxonomy page problems

Custom Taxonomy page problems

  • johnhanwell

    @johnhanwell

    Have one site in my wordpress network which has a customer taxonomy page.
    Has been working fine untill today. When you go to the page it comes up 404? I read that you have to go to your permlinks to reset which i tried and did work. I tried some old backups from about a month ago and still did not work. So reverted back to a backup from last night. I have tried swaping templates over and then back. Also remove the .htaccsess file and then dropping it back in blank. Had to go back to the old .htacsess. Still nothing?

    Any one got any ideas what else to try.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Moderator Ipstenu (Mika Epstein)

    @ipstenu

    What changed? It shouldn’t magically stop working without some intervention.

    johnhanwell

    @johnhanwell

    love to know lol. I working backwards right now but don’t understand why a backup won’t fix it?

    Have r1 back up and back the database up nightly too.

    johnhanwell

    @johnhanwell

    so the plot gets thicker.. I have installed it on to a single wordpress install and problem still there. So nothing wrong with the network. However when I want the single view of an item in my custom taxanomy it work fine. That is I have the permlinks set to default. However the taxanomy-xxx.php page does not come up for the group of items.

    johnhanwell

    @johnhanwell

    my taxonomy is taxonomy-product-range.php and when i type in address/product/ the page goes the index.php when I try address/product-range/ it does the same thing.

    I getting a bit confused over what suppose to come up when?

    add_action('init', 'catalog_init');
    function catalog_init()
    {
      $labels = array(
        'name' => _x('Products', 'post type general name'),
        'singular_name' => _x('Product', 'post type singular name'),
        'add_new' => _x('Add New', 'product'),
        'add_new_item' => __('Add New Product'),
        'edit_item' => __('Edit Product'),
        'new_item' => __('New Product'),
        'view_item' => __('View Product'),
        'search_items' => __('Search Products'),
        'not_found' =>  __('No products found'),
        'not_found_in_trash' => __('No products found in Trash'),
        'parent_item_colon' => '',
        'menu_name' => 'Products'
    
      );
      $args = array(
        'labels' => $labels,
        'public' => true,
        'publicly_queryable' => true,
        'show_ui' => true,
        'show_in_menu' => true,
        'query_var' => true,
        'rewrite' => true,
        'capability_type' => 'post',
        'has_archive' => true,
        'hierarchical' => false,
        'menu_position' => null,
        'menu_icon' => get_bloginfo('template_url') . '/images/producticon.png',
        'supports' => array('title','editor','thumbnail','custom-fields')
      );
      register_post_type('product',$args);
    }
    
    register_taxonomy("product-range", array("product"), array("hierarchical" => true, "label" => "Product Range","capabilities" => array('manage_terms'), "singular_label" => "Product", "rewrite" => true));
    johnhanwell

    @johnhanwell

    tried

    flush_rewrite_rules( false );

    still not working

    johnhanwell

    @johnhanwell

    so narrowed it down to the fact that the archive-products.php keeps going to the front page when you type address/products/

    Does any one know what it does this?

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Custom Taxonomy page problems’ is closed to new replies.
Skip to toolbar