WordPress.org

Support

Support » Plugins and Hacks » Advanced Post List » custom taxonomy filter not working

custom taxonomy filter not working

  • Hi
    I have a website with one custom post type that has a taxonomy named ‘project-type’
    I created a preset using the filter to show list of posts for each term in the taxonomy
    until yesterday it worked fine and than i change the list content of the preset and saved it.
    now the list show all pages and post of the website
    the filtering does work when I use pages or parent pages
    any idea?
    thanks

    http://wordpress.org/plugins/advanced-post-list/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author EkoJR

    @ekojr

    I’m not sure how you have it set up exactly with the terms, but have you tried using the any/all option? Seems odd it would work and then all of a sudden just quit working, have you tried making a new preset? I wonder if the post_type/taxonomy of the preset got corrupted somehow.

    Plugin Author EkoJR

    @ekojr

    Actually, I think I see what’s going wrong, and the code is gonna be getting replaced before 0.3 stable is released.

    So, for now, I’m just gonna have to say sit tight and wait for the next release. It’s a bit much to explain a fix on here, and will be irrelevant as soon as the new code is out.

    thanks,
    when do you expect the update to be released?
    Iam in the middle of a project and can’t wrap things without fixing this.
    do you think you can try help fix this in the meanwhile?
    thanks

    Plugin Author EkoJR

    @ekojr

    In about 1-2 weeks.

    Like I said, gonna have to hold tight. I’ve looked it over for an immediate fix, but right now it’s too complex to offer one.

    Plugin Author EkoJR

    @ekojr

    Actually, I take that back. There’s a possible fix for this in the apl_query_mod branch on GitHub. Just download that, and replace the advenced-post-list folder.

    There’s a bunch of code being worked on, but it shouldn’t conflict with anything.

    thanks
    unfortunately, that did not fix the issue.
    i will look for another solution

    Plugin Author EkoJR

    @ekojr

    Sorry I couldn’t provide a fix for you, but I know that branch has a quick fix for using page_parents with post_types and taxonomies (including the current post setting). So this might be a fix for something.

    However, could you provide information on how exactly your Post_Type/Taxonomy is set up with the terms? Might help.

    Btw, check to make sure no exclude settings are selected too.

    Hi
    i have a post type named ‘project’ with a taxnomy named ‘project-type’
    there are three terms for the taxonomy: mini,midi,multi
    Iam trying to create a list of posts tagged under these terms for each one

    everything worked before and then I edit the list content {just added a class to the UL}
    when I save the preset it stopped filtering and shows all post and pages
    maybe I can send you the access to the admin by mail if it;s ok with you
    so you can have a better idea
    thanks for the effort

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘custom taxonomy filter not working’ is closed to new replies.
Skip to toolbar