Support » Plugin: WP CSV » Custom Taxonomies not present in export file

  • Resolved theMikeD

    (@themiked)



    Hi there, having trouble with something.

    I have a site made up of ACF entires, custom post types and custom taxonomies.

    If I export everything use WP CSV and open the file in Excel, everything is exported except the custom taxonomies. Is there a trick to getting them to export as well? There doesn’t seem to be a way to explicitly select them in the GUI.

    https://wordpress.org/plugins/wp-csv/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author CPK Web Solutions

    (@cpkwebsolutions)

    Hi Mike

    The custom taxonomies should appear if there’s at least one post in the export and it has at least one term set.

    I just did a quick test on a fresh WP install with the types plugin used to quickly create a custom post type and a custom taxonomy. It exported no problem.

    So, first impression is that it’s likely to be something specific about your site. Another plugin may be interfering with normal operation for instance. Perhaps try deactivating all plugins except WP-CSV and ACF.

    Best wishes

    Paul

    theMikeD

    (@themiked)

    OK. that explains it. In my case the CT is not assigned directly, it is a data source for the ACF setup. Is there a way to force it to be exported? Much like the hide_empty=false bit of get_terms?

    Plugin Author CPK Web Solutions

    (@cpkwebsolutions)

    Hi Mike

    I’m not familiar with the ACF ‘data source’ functionality you mention, but if the end result is a custom field attached to a post, then WP CSV should export it. To make the column heading appear, you’d just need one post that has that Custom Field set. You can also add custom field columns to the CSV file manually (just make sure it’s next to another CF, as position matters).

    Best wishes

    Paul

    theMikeD

    (@themiked)

    It’s not specific functionality, it’s just a way to use CT terms. In a nutshell, the CT terms are created but not attached to any post, page or CPT directly; instead they are used as a source for entires in an ACF repeater field. Nothing magical.

    So just to confirm: there is no way to for the export of empty (in the same sense as ‘hide_empty” get_terms() option) terms, is that right?

    If position matters, can you clarify what you mean please?

    Plugin Author CPK Web Solutions

    (@cpkwebsolutions)

    Sorry, no. I think you’d need to modify the plugin to achieve that.

    Best wishes

    Paul

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Custom Taxonomies not present in export file’ is closed to new replies.