Support » Plugin: F4 Media Taxonomies » Custom taxonomies do not work/show

  • Resolved Enterprise Branding

    (@enterprisebranding)


    Hi.

    This is nice. However, I could not get the custom taxonomies to show.

    add_action('init', function() {
        register_taxonomy(
            'yourtaxonomyname',
            'attachment'
        );
    });

    They just simply do now show in the drop downs. I’ve experimented, looked at the codex and things for about 30 minutes. Am I missing something? I’m wondering if maybe the hook is just firing too late or too early? However, I tried an earlier hook and boom, site down, lol.

Viewing 3 replies - 1 through 3 (of 3 total)
  • visnevskis

    (@visnevskis)

    For me the drop-downs do not show up at all after activating the plugin.

    Plugin Author FAKTOR VIER

    (@faktorvier)

    @enterprisebranding

    Sorry vor the late answer… Is it working correctly in the meantime? Or is this still a problem? If yes, have you tried to assign the taxonomy not directly with the register_taxonomy function, but instead with the register_taxonomy_for_object_type(‘yourtaxonomyname’, ‘attachment’); function?

    @visnevskis

    If you just active the plugin, no dropdown will appear. You just have to register a taxonomy and assign it to the “attachment” post type. Or assign an existing taxonomy. Please check the code snippet from the plugin FAQ or post your code so we can check if there is something wrong with it.

    Enterprise Branding

    (@enterprisebranding)

    Hi! Yes. Sorry. When I read this I misunderstood a little. I got it to work well.

    Thank you.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Custom taxonomies do not work/show’ is closed to new replies.