Support » Fixing WordPress » Custom Taxonomies admin box broken after WP3 upgrade.

  • Hi there.
    After I upgrade from WP 3.0-RC1-15112 to WP 3.0, the Custom Taxonomies admin boxes stop working.

    The theme in question is a custom theme made from Sandbox, with custom taxonomies in functions.php

    I tried several recommendations with no success, such as switching the theme and deactivating the plugins.

    Tracking the issue with a dev version of the site (I did not update it) , I realize that the ID of the div is not recognizing the custom taxonomy; instead, the box ID is just like the tag box.
    The screenshot comparison, check the highlighted line:

    The Prod box site ID (wrong)
    The Dev box site ID (right, notice the id is “status”

    This is making the admin panel looks for the tags and not the custom taxonomies when consults via admin-ajax.php.

    Tried to create a new custom taxonomy, and changing the parameters does not work either 🙁

    This is my functions.php taxonomy code:

    add_action( 'init', 'create_my_taxonomies', 0 );
    function create_my_taxonomies() {
    	register_taxonomy( 'status', 'page', array(
    		'hierarchical' => false,
    		'label' => 'Status',
    		'query_var' => true,
    		'rewrite' => array( 'slug' => 'destacados' )
    	register_taxonomy( 'programas', 'page', array(
    		'hierarchical' => false,
    		'label' => 'Tipo de Programa',
    		'query_var' => true,
    		'rewrite' => array( 'slug' => 'programa' )

    Thanks in advance


Viewing 5 replies - 1 through 5 (of 5 total)
  • By the way, the problem is just the admin box, the taxonomy itself works. If I call the taxonomy like this (notice the “status=agenda” parameter:

    $posts = get_posts('post_type=page&status=agenda&order=ASC&orderby=date');

    it still works.

    PS: Sorry for my lousy english.

    I have the same issue. The ajax to add a new taxonomy term doesn’t work. Well it actually does but nothing changes on the page I have to refresh.

    I too have this issue.

    The error seems to be on Line 2 of admin-ajax.php

    It says: XML or text declaration not at start of entity

    Anybody got a fix?

    Moderator keesiemeijer



    – re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress by using FTP or whatever file management application your host provides.

    Thanks for the advice.

    Doesn’t seem to have resolved to the issue, though.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Custom Taxonomies admin box broken after WP3 upgrade.’ is closed to new replies.