Support » Plugin: WooCommerce » Custom tabs no longer showing – WooCommerce 2.01

  • Hi guys, i have some custom tabs and when i updated to woo 2.01 they have been replaced with this error:

    Warning: uasort() expects parameter 1 to be array, null given in /home/jayseven/public_html/woo/wp-content/plugins/woocommerce/woocommerce-template.php on line 792

    An example of my tab code below:

    //---------------------------------------------------------------------------add contact tab
    
    add_action('woocommerce_product_tabs', 'woocommerce_product_installation_tab', 50);
    add_action('woocommerce_product_tab_panels', 'woocommerce_product_installation_panel', 50);
    
    if (!function_exists('woocommerce_product_installation_tab')) {
    function woocommerce_product_installation_tab( $current_tab ) {
    global $_product;
    ?>
    <li <?php if ($current_tab=='#tab-installation') echo 'class="active"'; ?>><a href="#tab-installation"><?php _e('Contact', 'woocommerce'); ?></a></li>
    <?php
    }
    }   
    
    if (!function_exists('woocommerce_product_installation_panel')) {
    function woocommerce_product_installation_panel() {
    
    global $_product;
    
    echo '<div class="panel" id="tab-installation">';
    echo '<h2>' . apply_filters('woocommerce_product_installation_heading', __('Contact', 'woocommerce')) . '</h2>';
    echo '<h4> Contact us about ' . apply_filters( 'woocommerce_single_product_title', the_title( '', '', false ) ) . '</h4>';
    gravity_form(1, false, false, true, false, true);
     echo '</div>';
    
    }
    }

    Hopefully a simple fix, but urgently required!

    Thanks.

    http://wordpress.org/extend/plugins/woocommerce/

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘Custom tabs no longer showing – WooCommerce 2.01’ is closed to new replies.