Custom Tables
[custom tables] Search dosn`t work with polish letter (3 posts)

  1. krzys86
    Posted 3 years ago #

    I add to database few word with polish letter ( ń, ę) and when I tried use search - didn`t work. Without special polish point it works. Any idea to fix it ?? I need search word with polish point.


  2. Stefan M.
    Plugin Author

    Posted 3 years ago #

    Are these letters available in UTF8 Charset?

    Have you tried to set the correct Charset under settings?

    If that doens't help, make a ticket on the webpage wuk-custom-tables.com and I will try to fix it.


  3. krzys86
    Posted 3 years ago #

    Yes, I usualy use UTF8 for polish char and it work fine.

    I set Charset to UTF8 in database and converted plugin file form ASCII to UTF8 and it didn`t work. Now i use simple solution:

    $polish  = array("Ę" => "E","Ó" => "O", "Ą" => "A", "Ś" => "S", "Ł" => "L", "Ż" => "Z", "Ź" => "Z", "Ń" => "N" ,"ę" => "e", "ó" => "o", "ą" => "a", "ś" => "s", "ł" => "l", "ż" => "z", "ź" => "z", "ć" => "c", "ń" => "n");
    			$_GET['wctx'] = strtr($_GET['wcts'], $polish);
    			$searchqry = ($_GET['wcts'] != '' ? $_GET['wctx'] : $_GET['s']);

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Custom Tables
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic