Support » Plugin: WP Add Custom CSS » Custom stylesheet not loading?

  • Hello,
    Having trouble figuring out why custom stylesheet not loading on posts and custom post types, appreciate any help.
    No problem getting the custom css box to appear for posts and custom post types. After entering css on a particular post it does not load stylesheet. If I apply styles to the whole site from the plugin ‘settings’ these get applied ok. Issue only with css on individual posts and custom post types. Have tried deleting and reinstalling plugin, I have the plugin installed on other sites which are working ok.
    Any ideas where I could be going wrong?? Feels like I missing something simple…
    Working locally so difficult to share more.
    Thanks!

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Daniele De Santis

    (@danieledesantis)

    Hello,
    have you checked your page source to see if there’s a <style> block with your css rules your document head?

    Hi Daniele,
    Thanks for your reply! Yes, I have checked page source via Chrome dev tools. Here is a pic of files loading in doc head:
    stylesheets in doc head
    Here is pic of network tab:
    network tab

    • This reply was modified 1 year, 9 months ago by  nicknoop.

    Here is pic which illustrates the issue:
    issue illustration

    Plugin Author Daniele De Santis

    (@danieledesantis)

    Hi,
    css added using the metabox on post/page/custom-post-type is not applied using a stylesheet, but a

    <style>
    .. your css yere
    </style>

    block in the <head> of the document.

    The stylesheet with id “wp-add-custom-css-css” is used only for css rules added in the plugin settings page.

    In your screenshot I can’t see the full content of your <head>, could you provide one where all the content is visible?

    Thanks,
    Daniele

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Custom stylesheet not loading?’ is closed to new replies.