Support » Themes and Templates » Custom Single Template Issue

  • Resolved romitraj

    (@romitraj)


    Hello,

    We are working on a theme for our website. We have created a custom post type – minutes_of_meeting

    $labels = array(
    		    'name' => _x('Minutes of Meeting', 'post type general name', 'your_text_domain'),
    		    'singular_name' => _x('Minutes of Meeting', 'post type singular name', 'your_text_domain'),
    		    );
    		  $args = array(
    		    'labels' => $labels,
    		  	'public' => true,
    		  	'show_ui' => true,
    		 	'publicly_queryable' => true,
    		  	'exclude_from_search' => false,
    		  	'menu_position' => 20,
    		  	'query_var' => true,
    		  	'has_archive' => true,
    		  	'rewrite' => array('slug' => 'minutes_of_meeting', 'with_front' => false)
    		  );
    		  register_post_type('minutes_of_meeting', $args);

    I tried all settings on rewrites (no custom rewrites).

    The problem I am facing is that all the custom post types (minutes_of_meeting) are redirecting to single.php even though I have created single-minutes_of_meeting.php

    I saw others facing similar situations and the thing about visiting permalinks settings to refresh it etc didn’t help. Unlike others who were seeing 404 pages, I am seeing everything going to single.php.

    Any ideas as to what can cause this. I don’t know too much about the rewrite system in wordpress. can that cause this?

Viewing 1 replies (of 1 total)
  • Never mind. It got fixed on its own. I am working on MAMP on OSX 10.6.8. Maybe that had something to do with it. It didn’t work for over 2 hours and I had even restarted MAMP. Well, now it does.

Viewing 1 replies (of 1 total)
  • The topic ‘Custom Single Template Issue’ is closed to new replies.