WordPress.org

Forums

Custom Sidebars
[resolved] Custom sidebars not appearing in posts/pages (5 posts)

  1. s3korea48
    Member
    Posted 10 months ago #

    I installed this plugin and created a custom sidebar. I then edited a post but the dropdown list is not showing so i cant select any custom sidebar i created

    It only shows the following text, but not the dropdown list where i can assign a custom sidebar to that post

    You can assign specific sidebars to this post, just select a sidebar and the default one will be replaced, if it is available on your template.

    There are not replaceable sidebars selected. You can define what sidebar will be able for replacement in the Custom Sidebars config page.

    https://wordpress.org/plugins/custom-sidebars/

  2. WPMU DEV
    Member
    Plugin Contributor

    Posted 10 months ago #

    Hi @s3korea48,

    Greetings and thanks for posting on the forums.

    You should select the Replaceable Sidebars for substitution from the list displayed on the following path.

    Admin area -> Custom Sidebars -> Replaceable Sidebars

    Best Regards,
    WPMU DEV

  3. kylesalonga
    Member
    Posted 10 months ago #

    We're experiencing the same issue and have tried the above fix from WPMU DEV, however, still did not fix our problem.

    Here's a copy of the ongoing transcript from both ThemeNectar & WooCommerce to try to fix this issue.
    I'm curious what page template this uses as we've modified woocommerce.php but do not see the changes in the sub category pages. Please see the missing left sidebar below:

    http://dlc.bizcravedev.com/product-category/home-theatre-2/ - Appears

    http://dlc.bizcravedev.com/product-category/home-theatre-2/cool-components/ - Does not appear

    theme's author (Salient):
    Hey again!

    I've taken another look at the page & woocommerce.php file on your setup and can now see that the sidebar div is still actually getting placed on the page but the get_sidebar(); is returning nothing. Because of this it might be better to simply pose that question on the WooCommere forums to see if there's any known issues with calling that function on sub category pages. Also - have you made any mods to the functions.php or something else that could be interferring such the query get_sidebar() is trying to make?

    WooCommerce:
    Subcategory pages should show sidebars normally, like any regular WooCommerce page.

    To me it sounds like a theme issue. Please try switching to the WordPress default Twenty Thirteen theme temporarily to see if the issue persists. If so, then we can rule out an issue with the theme.

    Me:
    I've switched it to Twenty Thirteen. Same issue happens, see below:

    http://dlc.bizcravedev.com/product-category/home-theatre-2/ - Appears

    http://dlc.bizcravedev.com/product-category/home-theatre-2/cool-components/ - Does not appear

    WooCommerce:
    Apparently you are loading your sidebar with the following plugin: Custom sidebars. That's probably where the issue comes from.

    I tested locally and sub-categories do have a sidebar.

    It's a settings issue within this plugin, so I recommend you to contact the plugin's authors directly.

    If you experience any other issues, feel free to contact us and we will do our best to help you.

  4. David
    WPMU DEV Support Staff
    Posted 10 months ago #

    Hi @kylesalonga,

    I hope you're well today! :)

    Thanks for all those details, could I get you to create a new topic here:
    http://wordpress.org/support/plugin/custom-sidebars

    That'll help us to keep focus on the specifics you've described while also avoiding any confusion with the original post.

    I just wanted to mention too, the plugin's recently undergone a major update and it now works quite differently (more intuitively really). Perhaps you'd like to give it a go with that latest version? :)

    Thanks,
    David

  5. WPMU DEV - Your WordPress Team
    WPMU DEV Support Staff
    Plugin Author

    Posted 10 months ago #

    Hey there @s3korea48,

    We haven't heard back from you on this but we'd love to ensure it's all working for you. The topic's now marked as resolved but just let us know if you need any assistance.

    We'll be here to help. :)

    Regards
    WPMU DEV

Reply

You must log in to post.

About this Plugin

  • Custom Sidebars
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.