Support » Plugin: Custom Sidebars - Dynamic Sidebar Widget Area Manager » Custom Sidebars can not shows on front end

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hi @nd62

    I hope you are doing good today.

    Was there any update on your theme and plugins and past days and weeks?
    Also, did you make any changes on your site, like changes in theme settings or changes in Custom Sidebars?

    Please let us know also in your next reply what is your theme name you use on your site so we could replicate this on our side.

    Kind Regards,
    Kris

    Thread Starter nd62

    (@nd62)

    Hi

    thanks for the reply.

    – yes, it was theme updates in the last two weeks or so.

    – no, i did not do any changes.

    – i am using “publisher” theme.

    thanks

    Hi @nd62

    Thanks for response!

    Looking at homepage source code, it doesn’t seem like these sidebars are even loaded there – not that they are “hidden”. There are “areas” where they probably should be but they are “empty” in terms of any HTML markup inside.

    This suggests that something was indeed changed a bit “too much” on site and it might actually be the theme. Unfortunately, this seems to be premium theme and I don’t have any access to it to be able to test it but could you, just in case, duble-check

    – custom sidebars settings and if all the sidebars that should be replaced with custom ones have “Allow this sidebar to be replaced” option set
    – edit homepage and check if it has proper template selected – that allows sidebars?
    – if there’s any cache on site and/or server – clear that cache?

    Could you also take a screenshot of your custom sidebars configuration and share it with us, please?

    Best regards,
    Adam

    Thread Starter nd62

    (@nd62)

    Hi

    the “publisher” theme is only one theme.

    here is the sidebars:

    https://العنكبوت.com/sidebars.JPG

    here is the homepage backend:

    https://العنكبوت.com//home.JPG

    thanks

    Hello @nd62,

    As the screenshots do not give us more information, I would suggest a few steps you can take on your end to check and identify the issue.

    1. Check the visibility conditions and the sidebar locations are intact.

    If this a live site, please consider taking a backup before you start working on the following tests:

    2. Turn on debug logging to check if the site generates any errors. Here is how you can do that:

    Debugging in WordPress

    You can find more information on how to use debug logging to troubleshoot your issue, please check the following article:
    https://premium.wpmudev.org/blog/debugging-wordpress-how-to-use-wp_debug/

    3. After you turn it on, please visit your site a few times and then check if the debug.log file is generated. The above article would help you with the instructions on the same.

    If you see any errors, please send them to us here.

    4. Also do check the browser console to see if you have any errors there.
    I checked your site now but seems like someone is working or it looks to be broken to me which is why I could not do this on my end.

    5. If none of the above works, please consider doing a plugin conflict test. Here is how you can do that:
    https://premium.wpmudev.org/blog/wordpress-plugin-conflicts-how-to-check-for-them-and-what-to-do/

    Please let me know if you are able to resolve this with the steps I have suggested. If you do see an error in the debug log and things do not work please send the log to us here to check that further.

    Thank you,
    Prathamesh Palve

    Hello @nd62

    I’m closing this topic due to recent inactivity.
    Feel free to post back any update and we can re-open it and carry on troubleshooting.
    🙂

    Thank you,
    Dimitris

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Custom Sidebars can not shows on front end’ is closed to new replies.