Support » Plugin: Easy Custom Sidebars » Custom Sidebar Not Showing up on Products Archive (WooCommerce)

  • Resolved hirejordansmith

    (@hirejordansmith)


    Hey there! Long time user of this plugin, great work!

    I am seeing an issue after updating to the new version where the custom sidebar is not outputting on the Product Archive. There was previously an option for this and I still have in the Sidebar replacement > https://www.dropbox.com/s/t7rxf2swbea8y19/Screen%20Shot%202020-12-07%20at%209.55.26%20AM.png?dl=0

    However, it appears that it’s no longer supported or available in the options for selecting? I believe it was in the template hierarchy dropdown before?

    I also have the Product Archive set as the home page of the WordPress site. Not sure that is causing an issue? Thanks in advance for your help!

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Sunny Johal

    (@sunny_johal)

    Hi @hirejordansmith
    Thanks for reaching out. Is the issue that the sidebar replacement isn’t being applied? Or is it that it doesn’t appear as a replacement option in the admin area?

    Thread Starter hirejordansmith

    (@hirejordansmith)

    I think the core issue is that it’s not appearing as a replacement option in the admin area. I already had it set as an option from the previous version so it’s still in the ECS menu but I don’t see it as an option to select in the ECS menu anymore. So that is likely the core issue. Thoughts?

    Thread Starter hirejordansmith

    (@hirejordansmith)

    @sunny_johal – any updates on this issue? Thanks!

    Plugin Author Sunny Johal

    (@sunny_johal)

    Hi @hirejordansmith,
    Just so I fully understand the issue:

    You have created a page that is used as a product archive, set it as your homepage and the sidebar replacement is not taking effect?

    Thread Starter hirejordansmith

    (@hirejordansmith)

    @sunny_johal – I’ve made a quick video (under 2 min) going over the issue. You can view that here > http://videos.hirejordansmith.com/watch/crVflVPiUv

    I think the core issue is that I have the Shop Page set as the Home Page and this page is also the product-archive.php template so something in your plugin isn’t account for this specific setup I think?

    Please let me know if you have any other questions?

    Plugin Author Sunny Johal

    (@sunny_johal)

    The only reason this would be happening is if there is a custom WP_Query being defined that is interfering with the plugin.

    When you say the page is also the product-archive.php template what do you mean? Have you created a page template that pulls in this file?

    Reach out to me on support@titaniumthemes.com and I’ll look into it further.

    Thread Starter hirejordansmith

    (@hirejordansmith)

    @sunny_johal – just sent an email answering questions, thanks!

    Plugin Author Sunny Johal

    (@sunny_johal)

    Resolved.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Custom Sidebar Not Showing up on Products Archive (WooCommerce)’ is closed to new replies.