WordPress.org

Forums

Custom Sidebars
[resolved] Custom sidebar not showing up (10 posts)

  1. alanperlman
    Member
    Posted 1 year ago #

    Hi there,

    I'm using the latest version of this plugin, the latest version of WordPress, and this theme on a staging website: http://www.themezilla.com/themes/viewport/

    I've set up a custom sidebar to render on a specific page, and it's not showing up.

    I tried deactivating all plugins (except for the Custom Sidebar plugin), and that didn't work. I tried a live preview of TwentyTwelve and noticed that the sidebar shows up, so this indicates that it's an issue with this particular theme. Please help! Happy to pass along login details.

    Have used this plugin with another theme AND LOVE IT. It's brilliant.

    If it helps, here's the sidebar code I'm seeing in functions.php:

    if ( !function_exists( 'zilla_sidebars_init' ) ) {

    function zilla_sidebars_init() {
    register_sidebar(array(
    'name' => __('Main Sidebar', 'zilla'),
    'id' => 'sidebar-main',
    'before_widget' => '<div id="%1$s" class="widget %2$s">',
    'after_widget' => '</div>',
    'before_title' => '<h3 class="widget-title">',
    'after_title' => '</h3>',
    ));

    register_sidebar(array(
    'name' => __('Single Post Sidebar', 'zilla'),
    'id' => 'sidebar-single',
    'before_widget' => '<div id="%1$s" class="widget %2$s">',
    'after_widget' => '</div>',
    'before_title' => '<h3 class="widget-title">',
    'after_title' => '</h3>',
    ));

    register_sidebar(array(
    'name' => __('Page Sidebar', 'zilla'),
    'id' => 'sidebar-page',
    'before_widget' => '<div id="%1$s" class="widget %2$s">',
    'after_widget' => '</div>',
    'before_title' => '<h3 class="widget-title">',
    'after_title' => '</h3>',
    ));

    register_sidebar(array(
    'name' => __('Footer Column 1', 'zilla'),
    'id' => 'footer1',
    'before_widget' => '<div id="%1$s" class="widget %2$s">',
    'after_widget' => '</div>',
    'before_title' => '<h3 class="widget-title">',
    'after_title' => '</h3>',
    ));

    register_sidebar(array(
    'name' => __('Footer Column 2', 'zilla'),
    'id' => 'footer2',
    'before_widget' => '<div id="%1$s" class="widget %2$s">',
    'after_widget' => '</div>',
    'before_title' => '<h3 class="widget-title">',
    'after_title' => '</h3>',
    ));

    register_sidebar(array(
    'name' => __('Footer Column 3', 'zilla'),
    'id' => 'footer3',
    'before_widget' => '<div id="%1$s" class="widget %2$s">',
    'after_widget' => '</div>',
    'before_title' => '<h3 class="widget-title">',
    'after_title' => '</h3>',
    ));
    }

    }
    add_action( 'widgets_init', 'zilla_sidebars_init' );

    Also, here's the code from sidebar.php:

    <?php zilla_sidebar_before(); ?>
    <!--BEGIN #sidebar .aside-->
    <div id="sidebar" class="aside">

    <?php
    zilla_sidebar_start();

    /* Widgetised Area */
    if( is_page() ) {
    dynamic_sidebar( 'sidebar-page' );
    } elseif( is_single() ) {
    dynamic_sidebar( 'sidebar-single' );
    } else {
    dynamic_sidebar( 'sidebar-main' );
    }

    zilla_sidebar_end();
    ?>

    <!--END #sidebar .aside-->
    </div>
    <?php zilla_sidebar_after(); ?>

    https://wordpress.org/plugins/custom-sidebars/

  2. WPMU DEV
    Member
    Plugin Contributor

    Posted 1 year ago #

    Hi @alanperlman,

    Thank you for your question.

    I tried deactivating all plugins (except for the Custom Sidebar plugin), and that didn't work. I tried a live preview of TwentyTwelve and noticed that the sidebar shows up, so this indicates that it's an issue with this particular theme. Please help! Happy to pass along login details.

    As this is a theme specific issue i want to use this theme to troubleshoot and fix it but as the Viewport theme you are using is a premium theme i can't download it to test so please send me login details or the theme on the email id contact(at)wpmudev.org and include the URL of this thread in to it.

    Kind Regards,
    WPMU DEV

  3. alanperlman
    Member
    Posted 1 year ago #

    Thanks! Will do.

  4. WPMU DEV
    Member
    Plugin Contributor

    Posted 1 year ago #

    Hi @alanperlman,

    After sending it, just notify me on this thread.

    Cheers,
    WPMU DEV

  5. alanperlman
    Member
    Posted 1 year ago #

    Hi there, I sent an email w/ WP login information on 4/11. Received a response from David asking for a particular page where I was trying to load the custom sidebar. Replied back and am waiting on a response.

    Thanks!

  6. David
    WPMU DEV Support Staff
    Posted 1 year ago #

    Hi @alanperlman,

    Thanks for sending the details through. Fortunately, we didn't need to edit any theme files in this case. Just a matter of ensuring all the sidebar locations were selected at Appearance > Custom Sidebars.

    Then those locations could be accessed through the various Pages, where specific sidebars could be selected.

    I'll run this matter by the team though, to see if that could be made clearer maybe. Perhaps all the sidebar locations could be selected by default to make it all simpler. We'll have a look internally.

    Thanks,
    David

  7. Discman
    Member
    Posted 11 months ago #

    This appears to be an ongoing problem that effects numerous users, including me. I have them working on another site that uses the same theme, (Channel Theme). I can easily create a sidebar, using the same methods I use to create a page or a post . . . in fact, it is no different in any way. The problem is that none are displayed after linking them to whatever page I link them to . . . using all of the page sidebar related options at my disposal.

    For the longest time, I was unable to see the Sidebar Icon under the page option regardless of what changes I made. This is a very basic option for a WP user, so it should be as easy as changing a theme. I guess that I should choose a full page layout and include anything that would have gone into the sidebar.

  8. WPMU DEV
    Member
    Plugin Contributor

    Posted 11 months ago #

    Hi @Discman,

    Sorry to hear of the problem you are having.

    Could you please share me the page links where you want to display custom sidebar and also tell me how you have configured it so that i can troubleshoot to resolve your issue( Attach screenshot of it if you can )?

    For screenshots, you can simply provide a link to an image through Google Drive, Dropbox, screencast.com, http://imgur.com/ or other image service. :)

    Regards,
    WPMU DEV

  9. David
    WPMU DEV Support Staff
    Posted 10 months ago #

    Hey there @Discman,

    Looking back at this, I was wondering, is the plugin working for you now?

    Were you just commenting on the initial setup issue where the sidebar locations need to be selected at Appearance > Custom Sidebars?

    If not, could you please clarify?

    Thanks,
    David

  10. WPMU DEV - Your WordPress Team
    WPMU DEV Support Staff
    Plugin Author

    Posted 9 months ago #

    Hi there @Discman,

    We totally hear you and we've actually implemented a ton of changes to the plugin's interface with the recent updates.

    Lots of visual adjustments that make it very easy to work with, it's all very intuitive.

    We'd love to assist if you have any questions with it, just let us know if so. :)

    Cheers!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Custom Sidebars
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.