Support » Plugin: Custom Sidebars - Dynamic Widget Area Manager » Custom sidebar not showing on category archive pages

  • Resolved hospitalitydefender

    (@hospitalitydefender)



    Hello,

    The custom sidebar shows up on the individual blog posts for the specified category, but NO sidebar at all shows up on the category archive pages, which is what I really need. Can you assist? Thank you!

Viewing 15 replies - 1 through 15 (of 24 total)
  • Plugin Author jdailey

    (@jdailey)

    Thank you for using Custom Sidebars. First, make sure your theme has a sidebar built-in to the Archive page. Custom Sidebars does not add new sidebar areas, it dynamically replaces existing sidebars.

    If your theme does have a sidebar on the Archive page use sidebar location:

    Set the Archive pages:

    I hope that helps!

    Hi jdailey,

    I have the same problem as hospitalitydefender since I installed the latest plugin version. With the old version I did not experience any problem but right now the custom sidebar does only show up on the individual blog posts but not on categories anymore :-(.

    Do you have a rollback version or any idea what to do?
    Thank you!

    • This reply was modified 1 year, 6 months ago by  weber2017.
    • This reply was modified 1 year, 6 months ago by  weber2017.

    I also have this problem after updated to the latest version.

    Plugin Author Marcin Pietrzak

    (@iworks)

    Hi Guys!

    Could you export yours CSB settings and send it to me?

    marcin at incsub . com

    Thank you in advance!

    I will check it.

    Marcin

    Greetings,

    All of my Landing Pages (Category Archives) have also stopped displaying unique sidebar content. They have reverted to displaying what is on the home page. I’ve ruled out sidebar locations, and the checking off “allow Homepage content, sidebars to be replaced”

    This morning I changed one banner ad and it refused to display unless I was logged in. I had resorted to clearing the page cache from the WPengine host control panel to get the new banner to show up.

    This is when I noticed all my Landing Pages were displaying the same banner ads on the right sidebar. Landing pages are populated by category archives.

    http://fuelmarketernews.com

    My staging website still has Custom Sidebars 3.0.6 and it works just fine. It appears the error happened when I updated to 3.0.7.1

    I seem to be in the same boat. My staging site running 3.0.6 is still working as intended but my local dev machine that I have updated to 3.0.7.1 is having the issues described here.

    I have two sidebars. A standard WordPress sidebar on the posts page showing categories, and a custom sidebar on a portfolio page showing two custom taxonomies (Industry, Status) for a custom post type (Portfolio Company). The custom sidebar is set for the Portfolio page, and that much is working. But when clicking on an industry or status and viewing the archive for that post type, the custom sidebar is no longer displayed and instead the standard WordPress categories sidebar is displayed.

    In 3.0.6, the following image is how I have it set and it is working for the various taxonomies for the custom post type of portfolio companies:

    3.0.6

    But in 3.0.7.1, this setting no longer seems to be working. In fact, there are two new possible options that weren’t available in 3.0.6. Specifically, the two custom taxonomies seen here:

    3.0.7.1

    It looks like all I would need to do is select “Industry Archives” and “Status Archives”, however when I select them and click Save Changes, they aren’t actually saved. If I click “Sidebar Location” again after having saved changes, “Industry Archives” and “Status Archives” were not successfully added. Only “Portfolio Company Archives” still remains.

    Plugin Author Marcin Pietrzak

    (@iworks)

    Hi Guys

    I hope we found a problem, we are testing now release candidate with the fix.

    It will be published soon.

    Marcin

    Just to add to this: some archive pages can’t be added to a widget area.

    For example, in WooCommerce, there’s a product_cat and product_tag archive page, both of which refuse to save as a widget area location.

    This appears to be part of or closely related to this problem.

    • This reply was modified 1 year, 6 months ago by  jfacemyer.
    Plugin Author jdailey

    (@jdailey)

    Hello everyone! I just want to let you know we released a new version of Custom Sidebars with a fix for the archive option. Please update and let us know if you encounter any issues.

    Hmmm…I still can’t add the Product_cat and Product_tag archives. I select them, and they show up as a grey button, but they don’t stay when I hit “save changes”.

    Plugin Author jdailey

    (@jdailey)

    @jfacemyer this may be a conflict specific to your theme or a plugin you are running. To check for a conflict switch to a default theme and see if this resolves the issue. To test the plugins you can deactivate the other plugins and check if it works. If this resolves the issue reactivate your plugins one at a time until the issue returns. If you have a caching plugin you can try that first. Let us know if you find a conflict and we can try to resolve the issue.

    Also, if you can share your URL we can check for an error on the front end. Thank you for your feedback.

    I too am still having the same issue. It worked in 3.06, but 3.0.7.1 and 3.0.8 both seem to be not working as expected for me.

    I have both a custom theme and a custom plugin. I have swapped themes to the default 2017 theme but it made no difference. I can’t disable my custom plugin, as that is where I have added my custom taxonomies. But it worked in 3.0.6 just fine so I would have to assume it’s not my plugin anyway.

    @jfacemyer seems to be describing what I’m seeing:

    Image 1

    But after I click save they are gone:

    Image 2

    The thing is, in 3.0.6, the “Industry Archives” and “Status Archives” weren’t even available to select, and it worked fine without them. Now it doesn’t work without them, and I can’t select/save them anyway.

    Plugin Author jdailey

    (@jdailey)

    @ttamnedlog Thank you for the follow-up information. I was unable to replicate this behavior on my site I will ask our developer to take a closer look and see what he can find. Can you share a link to your site?

    Thank you for your help moving forward.

    @jdailey You’re welcome. Thanks for the ongoing support! The staging site is still using 3.0.6 since that is working for now. My client is still in the process of adding content on the staging site so I would hate to interfere with the functionality at the moment.

    I do have access to an old domain. Let me set up a copy of the site there and I will update that one to 3.0.8. I’ll share the link once I’ve done that. Give me a bit!

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘Custom sidebar not showing on category archive pages’ is closed to new replies.