Support » Plugin: Stream » Custom roles not tracking

  • Resolved joelworsham

    (@joelworsham)


    I have a couple custom roles created from a custom plugin. Users with these roles do not have their changes tracked for anything.

    One of the roles that does not work capabilities:

    'delete_others_pages' => true,
    'delete_others_posts' => true,
    'delete_pages' => true,
    'delete_posts' => true,
    'delete_private_pages' => true,
    'delete_private_posts' => true,
    'delete_published_pages' => true,
    'delete_published_posts' => true,
    'edit_others_pages' => true,
    'edit_others_posts' => true,
    'edit_pages' => true,
    'edit_posts' => true,
    'edit_private_pages' => true,
    'edit_private_posts' => true,
    'edit_published_pages' => true,
    'edit_published_posts' => true,
    'manage_categories' => true,
    'moderate_comments' => true,
    'publish_pages' => true,
    'publish_posts' => true,
    'read' => true,
    'read_private_pages' => true,
    'read_private_posts' => true,
    'unfiltered_html' => true,
    'upload_files' => true,

    https://wordpress.org/plugins/stream/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Luke Carbis

    (@lukecarbis)

    Hi joelworsham – could you tell me the plugin you used so I can test this for myself?

    Plugin Author Luke Carbis

    (@lukecarbis)

    Also – we just released a new version of Stream which has a fix for a possibly-related Roles issue. Can you check with version 3.0.5 to see if that has resolved your problem?

    It’s a custom plugin. Simply adds a role on plugin activation with the above capabilities.

    I updated to 3.0.5 and it still did not work. These are the steps I took:

    Switch to user with custom role
    Update post draft
    Switch back to admin user
    Update post draft again

    Switching (user switch plugin), and updating the draft for the admin worked and showed up, but the updating of the draft for the custom role user did not log at all.

    Plugin Author Luke Carbis

    (@lukecarbis)

    Thanks for that – very helpful. I’ve created a Github issue for this bug, we’ll aim to fix it in the next release. https://github.com/xwp/stream/issues/836

    Okay cool, thanks. Just to confirm, this bug seems to be present for users with custom roles without the User Switching plugin too right? Or have you only identified it with the plugin?

    For me, it does not track custom roles when using user switching, but also just normally.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Custom roles not tracking’ is closed to new replies.