WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Custom Posts not showing Admin Bar (7 posts)

  1. martiniboy
    Member
    Posted 3 years ago #

    Loving the new features of 3.3 beta especially the drag and drop uploader.

    On the admin bar (when you are viewing the site) from the dropdown to the quick links of dashboard (from li.wp-admin-bar-site-name) the custom posts are not displaying.

    Also it looks like that something is overwriting the function for custom the logo on login, double logo on login when using this in function

    add_action( 'login_head', 'my_custom_login_style', 99 );
     function my_custom_login_style() {
        print '<link rel="stylesheet" type="text/css" href="';
         print get_stylesheet_directory_uri();
         print '/login.css" media="screen" />' . "\n";
    }

    Logo image is now on the "h1 a" rather than the "h1"

    Finally still not able to rearrange menus while using an ipad, not able to drag and drop menu items

  2. You mean under the "Add New..." menu, you're not seeing your CPTs?

  3. martiniboy
    Member
    Posted 3 years ago #

    No under the name of the site where it has the quick links to everything in the sidebar of the admin - not a big problem but if you are going to have access to the other items it may as well replicate all.

  4. Ah thank you :)

    At a guess, they didn't want to add in the latency that a search for CPTs might cause.

  5. jason_lane
    Member
    Posted 3 years ago #

    It looks like in 3.3 beta 2 they've removed even more from the admin bar. In beta 1 the admin bar's "site name" menu provided an almost complete replica of the admin sidebar menu (except for custom post types). In beta 2, the "site name" menu now only gives us access to the items from the Appearance admin menu :-(

    I thought it was a nice feature to have the admin menu added to the admin bar, and it would have been very easy to add the CPT submenus (I was about to write some code to try it out). I hope they add the feature back in. I'm hoping they've just removed it temporarily due to some bugs/instabilities.

  6. martiniboy
    Member
    Posted 3 years ago #

    In a way that is better how it is in the latest beta, it leaves no room for the client to say why can I not access this from the admin bar but I can this, because they do not understand whether if it is a CPT or not.

    The Css still has not been changed for the h1 tag in login.css - Before the background image(logo) was on the h1 and now it is on the h1 a.
    Resulting in double logo if using custom logos.

    Still can not re-arrange menus using a touch screen(ipad) - will this be a feature of 3.3 or have I mis-read something?

  7. jason_lane
    Member
    Posted 3 years ago #

    I suppose it might be less confusing to clients. Anyway, the admin bar is easy enough to customize/extend, so adding the admin menu through a theme or plugin ought to be simple enough.

    BTW, I don't see the change you're talking about in the login.css In my 3.2.1 installs, the css is applied to the 'h1 a' not 'h1' One of my theme's custom login logo still works fine in 3.3b2, no double logo. Maybe something else is doing it?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.