Support » Plugin: MiniMU » Custom Post Types not working with MiniMU

  • Resolved jjust1

    (@jjust1)


    Really need some help here. MiniMU is the best solution I’ve found for my current project of running multiple domains that share WP content.

    However, with MiniMU active, I can’t get my custom post types to work.

    Here’s my custom post type

    // Custom Post Types
    add_action( 'init', 'create_my_post_types' );
    
    function create_my_post_types() {
    	register_post_type( 'media',
    		array(
    			'labels' => array(
    				'name' => __( 'Media' ),
    				'singular_name' => __( 'Media' ),
    				'add_new_item' => __( 'Add New Media' ),
    				'edit_item' => __( 'Edit Media' )),
    			'supports' => array( 'title', 'editor', 'custom-fields' ),
    			'public' => true,
    			'hierarchical' => true,)
    	);
    }

    With MiniMU active I get 404s for single posts and on pages that list all my custom posts I get nothing. Just blanks. Nothing.

    Thanks for your help

    http://wordpress.org/extend/plugins/minimu/

Viewing 3 replies - 1 through 3 (of 3 total)
  • think it got it. just settings for minimu. will report back.

    How were you able to solve this? My custom post still dont show up.

    yeah you can’t have custom post types with the same name as pages or in this case the same name as “media” since that is used by the media library. the site gets confused.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Custom Post Types not working with MiniMU’ is closed to new replies.