WordPress.org

Support

Support » Alpha/Beta » Custom post types in 3.0 multiuser using cusom permalinks?

Custom post types in 3.0 multiuser using cusom permalinks?

  • I’m developing a site using the RC2 of V3.

    I’m excited about custom post types, and have been testing them out!

    I’d ideally like to use custom permalinks for the site and have been previously using this format:

    /%category%/%postname%/

    It does not seem to work, it only seems to work with the default structure.. any insight?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Which ‘default structure’? Ugly permalinks or the YYYY/MM/DD one?

    Also, are you using RC1 or Beta2? There is no RC2 yet.

    Sorry Beta 2…

    and yes the ugly http://domain.url/?p=123 format is the only one that works….

    First try RC1 🙂 It’s newer.

    Did you update your .htaccess correctly?

    Do you have mod_rewrite enabled?

    here is my .htaccess:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]

    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ – [L]
    RewriteRule . index.php [L]
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    You’ve got duplicate stuff in there.

    If you’re using MultiSite, just have this:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]
    </IfModule>
    # END WordPress

    still doesnt work….

    wierd though, the page comes up when i do a search, but when i click the link i get the 404 page…

    I have a page-custompagetype.php file in my template as well….

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Custom post types in 3.0 multiuser using cusom permalinks?’ is closed to new replies.