Support » Fixing WordPress » Custom post types do not show up when child theme is Active

  • redemption55255

    (@redemption55255)


    Hello all, I have been put on my companies wordpress theme to build a custom child theme. I have followed everything in the child theme pages, but can’t seem to get all of the custom post-types registered in the parent-theme functions to appear in the child theme? Any thoughts?

Viewing 4 replies - 1 through 4 (of 4 total)
  • TrishaM

    (@trisham)

    If your parent Theme is registering custom post types, this sounds like a premium Theme, which this forum does not support.

    Even if it’s a free theme, your best bet is to contact the Theme developer for help, he/she will be better qualified to help you with your Child Theme.

    Also keep in mind that if your parent theme is itself a child theme (for example a genesis or other framework theme) then *your* theme is in fact a ‘grandchild’ them, which WP does not support.

    lisa

    (@contentiskey)

    I would suggest that you create a separate folder for your custom post type code instead of adding to the theme or child theme functions file. That is how I approach it so it doesn’t matter which theme is active.

    For example–on a recent site I launched…
    I have 4 custom post types. Each custom post type has a folder in my plugin directory.

    TrishaM

    (@trisham)

    @contentiskey – that’s always a good option when you’re *adding* custom post types (I put all of my theme-independent functions into one plugin), but it sounds like what @redemption55255 is experiencing is that the parent theme’s functions are not registering properly when the child theme is activated.

    This is a problem with the parent theme that should be fixed rather than worked-around, IMHO.

    lisa

    (@contentiskey)

    @TrishaM-I guess I misinterprested the nature of the support request.
    Thx for clarifying.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Custom post types do not show up when child theme is Active’ is closed to new replies.