Support » Plugin: BS3 Grid Builder » Custom Post types

  • Resolved kbatdorf

    (@kbat82)


    Doesn’t seem to work with my custom post types. When I select it fromt he settings, and hit save, it doesn’t save. However, if I look in the database the setting does update. When I go check the editor for the custom post type, however, nothing appears.

    Thanks

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Mahdi Yazdani

    (@mahdiyazdani)

    Hello

    Thanks for your report and using our plugin!
    Would you mind if I ask you to provide some info about the custom post type that you are using and your current WordPress installation environment?
    * WordPress Version
    * List of installed plugins
    * CPT Creator or any plugin that you are using to create it / or if you have created your own CPT manually, provide submitted $args to the CPT function “register_post_type”
    * PHP Version

    BS3 Grid Builder should be usable in any CPT with “the_content” filter.
    Maybe your custom post type doesn’t use “the_content” filter?

    Thanks!

    All support is handled via a dedicated support forum, available at Community Forums. Please head out there to open a new topic, in case you have any questions.

    Thanks for the reply.

    WP v 4.7.3
    No plugins except from the framework I’m using. http://framework.themosis.com/docs/1.3/introduction/

    PHP Version 7.0.8-2+deb.sury.org~xenial+1

    The framework has some helper classes but I guess it builds the Post Type by default with this:

            $args = wp_parse_args($args, [
                'label' => $defaultName,
                'public' => true,
                'exclude_from_search' => false,
                'show_in_admin_all_list' => true,
                'show_in_admin_status_list' => true,
                'label_count' => _n_noop($defaultName.' <span class="count">(%s)</span>', $defaultName.' <span class="count">(%s)</span>'),
                'publish_text' => __('Apply Changes'),
            ]);

    The problem isn’t on output, but I don’t even see the editor tabs on the custom post type. None of the assets are loading either. Is it maybe just not compatible with the framework?

    Thanks for the help

    Hey I figured out the issue. get_post_types() isn’t showing the custom post type, so I’m registering the custom post type too late in the process I guess.

    Experiencing the same problem. Latest version of WordPress, all plugins updated. We are using Toolset Types for CPT. The fields show in the BS3 configuration page, but when you check the boxes and save, they become unchecked.

    Plugin Author Mahdi Yazdani

    (@mahdiyazdani)

    There may be a plugin conflict with a 3rd party plugin – you can check that by disabling then reactivating a plugin one at a time to see if you find a conflict there.
    Also, it would be constructive if you could let me know what plugins and theme you are using on your website?

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Custom Post types’ is closed to new replies.