Support » Fixing WordPress » Custom Post Type UI, WP 3.04 & Menus

  • Resolved MTS

    (@sciarrin)


    Hi folks,

    Have noticed a strange bug since upgrading to WP 3.04 — the WP nav menu system has stopped working. I’ve narrowed it down to a conflict with Custom Post Type UI.

    When I navigate to Dashboard > Appearance > Menus, none of my menus show up on the page. Additionally, the following error appears in the meta box for the taxonomy within the Menu section:

    Catchable fatal error: Object of class WP_Error could not be converted to string in /home/mariat/plainparade.org/clawp/wp-includes/formatting.php on line 433

    Any suggestions for fixing this?

Viewing 9 replies - 1 through 9 (of 9 total)
  • esmi

    (@esmi)

    Have you tried:

    – deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Ten theme to rule out any theme-specific problems?

    resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

    MTS

    (@sciarrin)

    Yes, I deactivated ALL the plugins. That’s why I know it’s specifically the Custom Post Type UI plugin. I’ll give resetting the folder a shot. Thanks!

    esmi

    (@esmi)

    I think it’s far more likely that the issue is in your theme somewhere.

    MTS

    (@sciarrin)

    Nope, this is definitely not a theme problem, as I did try using the default theme to test your suggestion.

    Anyone have any other non-theme suggestions?

    esmi

    (@esmi)

    Don’t use the Custom Post Type UI plugin?

    MTS

    (@sciarrin)

    Thanks again for the suggestion, but I’m hoping other people might chime in at this point.

    Brad Williams

    (@williamsba1)

    This is the only report of this issue I’ve seen. My guess is some option data is corrupt from the plugin. Version 0.7 will have a way to reset the plugin back to defaults, but for now you could just delete any option values from the plugin in wp_options.

    YES- I have the same issue! If Custom Post Type UI is activated, then when I go to Appearance/Menus half of the boxes are missing and I get the same error message. I cannot add a menu, nor can I find the ones that already exist.
    On the front end, my menu is still visible and in tact, but I can’t access it from the back end.

    I’m also having a similar issue. When I try to add items to the menu, it the spinning wheel just continues to move without ever adding the item. As soon as I disable Custom Post Types UI, I can add a menu item in an instant.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Custom Post Type UI, WP 3.04 & Menus’ is closed to new replies.